MS11-021:Microsoft Excel 中的弱點可能會導致遠端程式碼執行 (2489279)

high Nessus Plugin ID 53378
新推出!弱點優先順序評分 (VPR)

Tenable 會為每個弱點計算動態 VPR。VPR 將弱點資訊與威脅情報和機器學習演算法加以結合,藉此預測攻擊者最有可能利用哪些弱點發動攻擊。查看詳細資訊: VPR 是什麼?它跟 CVSS 有何不同?

VPR 評分: 8.9

Synopsis

可透過 Microsoft Excel 在遠端主機上執行任意程式碼。

描述

遠端 Windows 主機正在執行受到多個弱點影響的 Microsoft Excel 或 Excel Viewer 版本。

若攻擊者可誘騙受影響主機上的使用者開啟特製的 Excel 檔,他們就可利用此問題執行需要該使用者權限的任意程式碼。

解決方案

Microsoft 已發佈一組適用於 Office XP、2003、2007、 2010、Excel Viewer 和 Office Compatability Pack 的修補程式。

另請參閱

https://docs.microsoft.com/en-us/security-updates/SecurityBulletins/2011/ms11-021

Plugin 詳細資訊

嚴重性: High

ID: 53378

檔案名稱: smb_nt_ms11-021.nasl

版本: 1.27

類型: local

代理程式: windows

已發布: 2011/4/13

已更新: 2018/11/15

相依性: smb_nt_ms02-031.nasl, office_installed.nasl, ms_bulletin_checks_possible.nasl, smb_hotfixes.nasl

風險資訊

風險因素: High

VPR 評分: 8.9

CVSS v2.0

基本分數: 9.3

時間分數: 8.1

媒介: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

時間媒介: CVSS2#E:H/RL:OF/RC:C

弱點資訊

CPE: cpe:2.3:a:microsoft:excel:*:*:*:*:*:*:*:*, cpe:2.3:a:microsoft:office:*:*:*:*:*:*:*:*, cpe:2.3:a:microsoft:excel_viewer:*:*:*:*:*:*:*:*, cpe:2.3:a:microsoft:office_compatibility_pack:*:*:*:*:*:*:*:*

必要的 KB 項目: SMB/MS_Bulletin_Checks/Possible

可被惡意程式利用: true

可輕鬆利用: Exploits are available

修補程式發佈日期: 2011/4/12

弱點發布日期: 2011/2/7

惡意利用途徑

CANVAS (White_Phosphorus)

Core Impact

Metasploit (MS11-021 Microsoft Office 2007 Excel .xlb Buffer Overflow)

參考資訊

CVE: CVE-2011-0105, CVE-2011-0097, CVE-2011-0980, CVE-2011-0101, CVE-2011-0103, CVE-2011-0979, CVE-2011-0098, CVE-2011-0978, CVE-2011-0104

BID: 46226, 46225, 47256, 47245, 47244, 47243, 47235, 47201, 46229

MSFT: MS11-021

EDB-ID: 18067, 18087

MSKB: 2464583, 2466146, 2466156, 2466158, 2466169, 2502786