CentOS 4 : seamonkey (CESA-2011:0313)

critical Nessus Plugin ID 52509
新推出!Plugin 嚴重性目前使用 CVSS v3

計算 Plugin 嚴重性已更新為預設使用 CVSS v3 沒有 CVSS v3 評分的 Plugin 會回歸到以 CVSS v2 計算嚴重性。您可在設定下拉式選單中切換顯示嚴重性的喜好設定

Synopsis

遠端 CentOS 主機缺少一個或多個安全性更新。

描述

現已提供適用於 Red Hat Enterprise Linux 4 的更新版 SeaMonkey 套件,可修正數個安全性問題。

Red Hat 安全性回應團隊已將此更新評為具有重大安全性影響。可針對每個弱點從〈參照〉一節的 CVE 連結中取得常見弱點評分系統 (CVSS) 的基本分數,其中包含有關嚴重性評等的詳細資訊。

SeaMonkey 是一款開放原始碼網頁瀏覽器、電子郵件及新聞群組用戶端、 IRC 聊天用戶端,以及 HTML 編輯器。

在 SeaMonkey 用於處理對話方塊的方法中發現一個瑕疵。攻擊者可利用此瑕疵建立一個惡意網頁,網頁中會顯示空白對話方塊,而其中的按鈕將不會有任何作用。如果使用者將對話方塊視窗關閉,就可意外授予提升權限給這個惡意網頁。(CVE-2011-0051)

處理格式有誤之網頁內容時發現多個瑕疵。包含惡意內容的網站可能會導致 SeaMonkey 當機,或可能利用執行 SeaMonkey 之使用者的權限來執行任意程式碼。(CVE-2011-0053)

在 SeaMonkey 用於處理執行 HTTP 要求之外掛程式的方法中發現一個瑕疵。如果有外掛程式執行 HTTP 要求,而伺服器傳送了 307 重新導向回應,外掛程式不會收到通知,但系統會轉寄 HTTP 要求。轉寄的要求可包含自訂標頭,從而導致跨網站要求偽造攻擊。
(CVE-2011-0059)

所有 SeaMonkey 使用者皆應升級至這些更新版套件,其可更正這些問題。安裝更新後,必須先重新啟動 SeaMonkey,變更才會生效。

解決方案

更新受影響的 seamonkey 套件。

另請參閱

http://www.nessus.org/u?48b3fdb0

http://www.nessus.org/u?4a067195

Plugin 詳細資訊

嚴重性: Critical

ID: 52509

檔案名稱: centos_RHSA-2011-0313.nasl

版本: 1.11

類型: local

代理程式: unix

已發布: 2011/3/3

已更新: 2021/1/4

相依性: ssh_get_info.nasl

風險資訊

VPR

風險因素: Medium

分數: 5.9

CVSS v2

風險因素: Critical

基本分數: 10

媒介: AV:N/AC:L/Au:N/C:C/I:C/A:C

弱點資訊

CPE: p-cpe:/a:centos:centos:seamonkey, p-cpe:/a:centos:centos:seamonkey-chat, p-cpe:/a:centos:centos:seamonkey-devel, p-cpe:/a:centos:centos:seamonkey-dom-inspector, p-cpe:/a:centos:centos:seamonkey-js-debugger, p-cpe:/a:centos:centos:seamonkey-mail, cpe:/o:centos:centos:4

必要的 KB 項目: Host/local_checks_enabled, Host/CentOS/release, Host/CentOS/rpm-list

修補程式發佈日期: 2011/3/3

弱點發布日期: 2011/3/2

參考資訊

CVE: CVE-2011-0051, CVE-2011-0053, CVE-2011-0059

RHSA: 2011:0313