OpenSSL < 0.9.8q / 1.0.0c 多個弱點

high Nessus Plugin ID 51058
新推出!Plugin 嚴重性目前使用 CVSS v3

計算 Plugin 嚴重性已更新為預設使用 CVSS v3 沒有 CVSS v3 評分的 Plugin 會回歸到以 CVSS v2 計算嚴重性。您可在設定下拉式選單中切換顯示嚴重性的喜好設定

Synopsis

遠端 Web 伺服器受到多個弱點影響。

描述

根據其標題,遠端 Web 伺服器執行的 OpenSSL 版本比 0.9.8q 或 1.0.0c 舊。這些版本可能受到多個弱點影響:

- 可修改儲存的工作階段快取加密套件來將加密套件降級至較弱版本。

- J-PAKE 實作中存在一個錯誤,可導致不知道共用密碼的人成功驗證。

解決方案

升級至 OpenSSL 0.9.8q / 1.0.0c 或更新版本。

另請參閱

https://www.openssl.org/news/secadv/20101202.txt

http://seb.dbzteam.org/crypto/jpake-session-key-retrieval.pdf

Plugin 詳細資訊

嚴重性: High

ID: 51058

檔案名稱: openssl_1_0_0c.nasl

版本: 1.12

類型: remote

系列: Web Servers

已發布: 2010/12/7

已更新: 2018/7/16

相依性: http_version.nasl

組態: 啟用 Paranoid 模式

風險資訊

VPR

風險因素: Medium

分數: 5.8

CVSS v2

風險因素: High

基本分數: 7.5

時間分數: 5.5

媒介: AV:N/AC:L/Au:N/C:P/I:P/A:P

時間媒介: E:U/RL:OF/RC:C

弱點資訊

CPE: cpe:/a:openssl:openssl

必要的 KB 項目: Settings/ParanoidReport

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2010/12/2

弱點發布日期: 2010/12/2

參考資訊

CVE: CVE-2010-4180, CVE-2010-4252

BID: 45163, 45164

Secunia: 42473