PHP < 5.3.2 / 5.2.13 多種弱點

medium Nessus Plugin ID 44921

Synopsis

遠端 Web 伺服器使用受到多個缺陷影響的 PHP 版本。

描述

根據其標題,遠端主機上安裝的 PHP 版本比 5.3.2 / 5.2.13 舊。這些版本可能會受到多個安全性問題影響:

- 結尾不是「/」的目錄路徑可能無法在「safe_mode」設定中的「tempnam()」內正確驗證。

- 由於工作階段延伸中的錯誤,導致攻擊者可以繞過「open_basedir」/「safe_mode」設定限制。

- 不明弱點影響 LCG Entropy。

解決方案

升級至 PHP 5.3.2 / 5.2.13 版或更新版本。

另請參閱

http://securityreason.com/achievement_securityalert/82

http://securityreason.com/securityalert/7008

https://seclists.org/fulldisclosure/2010/Feb/208

http://www.php.net/releases/5_3_2.php

http://www.php.net/ChangeLog-5.php#5.3.2

http://www.php.net/releases/5_2_13.php

http://www.php.net/ChangeLog-5.php#5.2.13

Plugin 詳細資訊

嚴重性: Medium

ID: 44921

檔案名稱: php_5_2_13.nasl

版本: 1.17

類型: remote

系列: CGI abuses

已發布: 2010/2/26

已更新: 2022/4/11

組態: 啟用徹底檢查

風險資訊

VPR

風險因素: Medium

分數: 5.3

CVSS v2

風險因素: Medium

基本分數: 6.4

時間分數: 5

媒介: AV:N/AC:L/Au:N/C:P/I:P/A:N

時間媒介: E:POC/RL:OF/RC:C

弱點資訊

CPE: cpe:/a:php:php

必要的 KB 項目: www/PHP

可輕鬆利用: No exploit is required

修補程式發佈日期: 2010/2/25

弱點發布日期: 2010/2/11

參考資訊

CVE: CVE-2010-1128, CVE-2010-1129, CVE-2010-1130

BID: 38182, 38430, 38431

SECUNIA: 38708