PHP < 5.2.11 多種弱點

high Nessus Plugin ID 41014

Synopsis

遠端 Web 伺服器使用受到多個缺陷影響的 PHP 版本。

描述

根據其標題,遠端主機上安裝的 PHP 版本舊於 5.2.11。這些版本可能會受到多個安全性問題影響:

- 「php_openssl_apply_verification_policy」中的憑證驗證發生不明錯誤。

- 不明輸入驗證弱點會影響「imagecolortransparent()」中的色彩索引。

- 不明輸入驗證弱點會影響 exif 處理。

- 以無效模式呼叫「popen()」可能導致 Windows 損毀。(錯誤 #44683)

- 「xml_utf8_decode()」中存在整數溢位,這可能導致攻擊者更容易使用採用 UTF-8 編碼的特製長字串繞過跨網站指令碼處理和 SQL 插入保護機制。(錯誤 #49687)

- 「proc_open()」可繞過「safe_mode_protected_env_vars」。
(錯誤 #49026)

解決方案

升級至 PHP 5.2.11 版或更新版本。

另請參閱

http://www.php.net/ChangeLog-5.php#5.2.11

http://www.php.net/releases/5_2_11.php

http://news.php.net/php.internals/45597

http://www.php.net/ChangeLog-5.php#5.2.11

Plugin 詳細資訊

嚴重性: High

ID: 41014

檔案名稱: php_5_2_11.nasl

版本: 1.20

類型: remote

系列: CGI abuses

已發布: 2009/9/18

已更新: 2022/4/11

組態: 啟用徹底檢查

風險資訊

VPR

風險因素: Medium

分數: 6.7

CVSS v2

風險因素: High

基本分數: 7.5

時間分數: 5.9

媒介: AV:N/AC:L/Au:N/C:P/I:P/A:P

時間媒介: E:POC/RL:OF/RC:C

弱點資訊

CPE: cpe:/a:php:php

必要的 KB 項目: www/PHP

可輕鬆利用: No exploit is required

修補程式發佈日期: 2009/9/16

參考資訊

CVE: CVE-2009-3291, CVE-2009-3292, CVE-2009-3293, CVE-2009-3294, CVE-2009-4018, CVE-2009-5016

BID: 36449, 44889

SECUNIA: 36791

CWE: 20, 134, 264