PHP < 5.2.10 多種弱點

medium Nessus Plugin ID 39480

Synopsis

遠端 Web 伺服器使用受到多個弱點影響的 PHP 版本。

描述

根據其標題,遠端主機上安裝的 PHP 版本舊於 5.2.10。報告指出這些版本受到多個弱點的影響:

- 未針對為函式「exif_read_data()」位移保留的欄位執行充足的檢查。成功惡意利用這個問題可導致拒絕服務情況。(錯誤 48378)

- 假使未設定「safe_mode_exec_dir」(預設為未設定),則在 Windows 上執行 PHP 的系統中,於「exec()」、「system()」、「shell_exec()」、「passthru()」和「popen()」等函式前加上反斜線,就可以繞過「safe_mode」限制。(錯誤 45997)

解決方案

升級至 PHP 5.2.10 版或更新版本。

另請參閱

https://bugs.php.net/bug.php?id=45997

https://bugs.php.net/bug.php?id=48378

http://www.php.net/releases/5_2_10.php

http://www.php.net/ChangeLog-5.php#5.2.10

Plugin 詳細資訊

嚴重性: Medium

ID: 39480

檔案名稱: php_5_2_10.nasl

版本: 1.14

類型: remote

系列: CGI abuses

已發布: 2009/6/22

已更新: 2022/4/11

組態: 啟用徹底檢查

風險資訊

VPR

風險因素: Low

分數: 3.6

CVSS v2

風險因素: Medium

基本分數: 5.1

時間分數: 3.8

媒介: AV:N/AC:H/Au:N/C:P/I:P/A:P

時間媒介: E:U/RL:OF/RC:C

弱點資訊

CPE: cpe:/a:php:php

必要的 KB 項目: www/PHP

可輕鬆利用: No exploit is required

修補程式發佈日期: 2009/6/18

弱點發布日期: 2009/5/24

參考資訊

CVE: CVE-2009-2687

BID: 35435, 35440

SECUNIA: 35441

CWE: 20