AlmaLinux 9.2 [TuxCare] 安全性更新:openssl / openssl-devel / openssl-libs / openssl-perl 多個弱點 (ALMALINUX9.2:CLSA-2026:1782976762)

medium Nessus Plugin ID 362281

概要

AlmaLinux 主機缺少一或多個安全性更新。

說明

AlmaLinux 9.2 主機已安裝的套件會受到 TuxCare ALMALINUX9.2:CLSA-2026:1782976762 公告中提及的多個弱點影響。

- 問題摘要:AES-SIV (RFC 5297) 和 AES-GCM-SIV (RFC 8452) 的實作未正確處理具有空密文的 AAD (附加驗證資料) 的驗證,因而允許偽造此類訊息。影響摘要:攻擊者可以使用這些加密方式,向受害者的應用程式偽造帶有任意 AAD 的空白訊息。AES-SIV (RFC 5297) 和 AES-GCM-SIV (RFC 8452) 是防隨機濫用的 AEAD 模式:它們接受金鑰、隨機、選用 AAD (已驗證但未加密的位元組) 和純文字,並產生密文加上 16 位元組標籤。解密期間,只有在標籤成功驗證時,「EVP_DecryptFinal_ex()」才會記錄為傳回成功。在這些加密方式的 OpenSSL 提供者實作中,只有在使用非空白資料叫用解密函式時,才會計算預期的標籤。如果調用端提供 AAD,然後呼叫「EVP_DecryptFinal_ex()」,而不叫用加密文字更新 (當收到的加密文字長度為零時可能會發生),則系統永遠不會重新計算標籤,且仍會保留其全零值。使用 AES-GCM-SIV 時,傳送任意 AAD、空密文和全零標籤的攻擊者會以他們不知道的任何金鑰通過身份驗證 (僅單次)。使用 AES-SIV 時,若要實現掛載攻擊,應用程式必須重複使用解密內容,而不重設金鑰。AES-SIV 是從 OpenSSL 3.0 開始實作的。AES-GCM-SIV 是從 OpenSSL 3.2 開始實作的。OpenSSL 本身 (TLS/CMS/PKCS7/HPKE/QUIC) 實作的任何通訊協定均不支援 AES-GCM-SIV 或 AES-SIV。若要實現掛載攻擊,應用程式必須實作自己的通訊協定,並使用 EVP 介面。此外,當帶有空密文的訊息到達時,他們必須跳過密文更新。4.0、3.6、3.5、3.4 和 3.0 中的 FIPS 模組不受此問題影響,因為這些演算法未經 FIPS 核准,且受影響程式碼位於 OpenSSL FIPS 模組邊界之外。(CVE-2026-45446)

- 問題摘要:當 CMS 密碼型解密 (RFC 3211/PWRI 金鑰解包) 處理攻擊者提供的 CMS 資料時,攻擊者選擇的串流模式 KEK 加密可觸發 kek_unwrap_key() 中的堆積超出邊界讀取。影響摘要:如果輸入緩衝區在記憶體頁面界限處結束,且下一頁未對應,堆積緩衝區過度讀取可能會觸發損毀,進而導致應用程式拒絕服務。由於過度讀取的位元組不會洩露給攻擊者,因此不會洩露資訊。金鑰展開函式會執行 RFC 中指定的檢查位元組測試,該測試會根據訊息中包裝的金鑰長度,從堆積配置中讀取 7 個位元組。會根據包裝密碼的區塊長度進行最小長度檢查。不過,加密是從攻擊者的 PWRI keyEncryptionAlgorithm 中攜帶的 OID 中選取,而不要求加密必須是區塊密碼。當攻擊者選取串流模式加密時,防護將無效,而且包含未包裝金鑰的配置緩衝區可能太小,不符合 RFC 中指定的檢查位元組,進而可能導致緩衝區過度讀取。在不受信任的 CMS 資料上調用 CMS_decrypt() 或 CMS_decrypt_set1_password()
的應用程式 (相當於 openssl cms-decrypt -pwri_password ...) 容易受到此問題的影響。不需要任何密碼知識:在任何驗證成功之前,會在嘗試展開期間發生過度讀取。過度讀取僅限於幾個位元組,不會寫入輸出,因此不會有資訊洩露。
觸發損毀需要配置的邊界緊鄰未對應的記憶體,這對於一般配置器來說不太可能發生。FIPS 模組不受此問題影響。(CVE-2026-9076)

請注意,Nessus 並未測試這些問題,而是僅依據應用程式自我報告的版本號碼作出判斷。

解決方案

根據 TuxCare 公告 ALMALINUX9.2:CLSA-2026:1782976762 中的指引更新受影響的套件。

另請參閱

https://cve.tuxcare.com/els/releases/CLSA-2026:1782976762

http://www.nessus.org/u?a39a7ede

Plugin 詳細資訊

嚴重性: Medium

ID: 362281

檔案名稱: tuxcare_alma_linux_9.2_CLSA-2026-1782976762.nasl

版本: 1.1

類型: Local

已發布: 2026/10/1

已更新: 2026/10/1

支援的感應器: Continuous Assessment, Nessus Agent, Tenable Cloud Security, Tenable Self-Hosted Container Security, Nessus

風險資訊

VPR

風險因素: Medium

分數: 5

百分位數: 93.74

Vendor

Vendor Severity: Moderate

CVSS v2

風險因素: Medium

基本分數: 5

時間性分數: 3.7

媒介: CVSS2#AV:N/AC:L/Au:N/C:N/I:P/A:N

CVSS 評分資料來源: CVE-2026-45446

CVSS v3

風險因素: Medium

基本分數: 4.8

時間性分數: 4.2

媒介: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N

時間媒介: CVSS:3.0/E:U/RL:O/RC:C

弱點資訊

必要的 KB 項目: Host/OS/extended-third-party, Host/local_checks_enabled, Host/AlmaLinux/release, Host/AlmaLinux/rpm-list, Host/cpu

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2026/7/2

弱點發布日期: 2026/6/9

參考資訊

CVE: CVE-2026-45446, CVE-2026-9076

CLSA: 2026:1782976762