php5 < 5.2.7 多個弱點

high Nessus Plugin ID 35043

Synopsis

遠端 Web 伺服器使用受到多個弱點影響的 PHP 版本。

描述

根據其標題,遠端主機上安裝的 PHP 版本舊於 5.2.7。因此,該應用程式受到多個弱點影響:

- 配套的 PCRE 程式庫中具有一個緩衝區溢位缺陷,會導致拒絕服務攻擊。
(CVE-2008-2371)

- 「posix_access」、「chdir」和「ftok」等函式中存在多個目錄遍歷弱點,會讓遠端攻擊者繞過「safe_mode」限制。 (CVE-2008-2665 和 CVE-2008-2666)

- 處理長訊息標頭時,因為過時的 API 呼叫,可能會觸發「php_imap.c」中的緩衝區溢位缺陷。此缺陷可能會遭到惡意利用,進而引發拒絕服務或執行任意程式碼。
(CVE-2008-2829)

- 指定特製字型時,可能會觸發 'ext/gd/gd.c' 之 'imageloadfont' 函式中的緩衝區溢位。此缺陷可能會遭到惡意利用,進而引發拒絕服務或執行任意程式碼。(CVE-2008-3658)

- PHP 的內部函式「memnstr」存在緩衝區溢位缺陷,可能會遭攻擊者對函式「explode」使用分隔符號引數而對其惡意利用。這可能用來引發拒絕服務或執行任意程式碼。(CVE-2008-3659)

- 將 PHP 作為 FastCGI 模組使用時,攻擊者若要求副檔名前有多個點的檔案,就可以引發拒絕服務。
(CVE-2008-3660)

- 副檔名 mbstring 中的堆積式緩衝區溢位缺陷,可以透過包含 Unicode 轉換期間未處理的 HTML 實體之特製字串來觸發。此缺陷可能會遭到惡意利用,進而執行任意程式碼。(CVE-2008-5557)

- 將 PHP 作為 Apache 模組使用時,由於 SAPI「php_getuid」函式多載,全域變數「page_uid」和「page_gid」的不當初始化會允許繞過安全性限制。(CVE-2008-5624)

- 當「safe_mode」透過「httpd.conf」中的「php_admin_flag」設定啟用時,PHP 不會施行正確的限制。這會讓攻擊者在「.htaccess」中放置特製的「php_value」項目,藉此寫入任意檔案。
(CVE-2008-5625)

- 副檔名 ZipArchive 中的函式「ZipArchive: : extractTo」無法從檔名篩選目錄遍歷序列。攻擊者可惡意利用這個項目,藉此寫入任意檔案。(CVE-2008-5658)

- 在有限情況下,攻擊者可以在呼叫具有無效引數的函式「dba_replace」時引發檔案截斷。(CVE-2008-7068)

- 檔案「xmlrpc.c」中的函式「date_from_ISO8601」存在緩衝區溢位錯誤,因為使用者提供的輸入驗證不當。
此弱點可能會遭到遠端攻擊者惡意利用,進而引發拒絕服務或執行任意程式碼。
(CVE-2014-8626)

解決方案

升級至 PHP 5.2.8 版或更新版本。

請注意,版本 5.2.7 已從發佈中移除,因為該版本中的迴歸導致「magic_quotes_gpc」設定即使設為開啟,仍會維持關閉狀態。

另請參閱

http://cxsecurity.com/issue/WLB-2008110041

http://cxsecurity.com/issue/WLB-2008110058

http://cxsecurity.com/issue/WLB-2008120011

https://seclists.org/fulldisclosure/2008/Jun/237

https://seclists.org/fulldisclosure/2008/Jun/238

https://www.openwall.com/lists/oss-security/2008/08/08/2

https://www.openwall.com/lists/oss-security/2008/08/13/8

https://seclists.org/fulldisclosure/2008/Nov/674

https://seclists.org/fulldisclosure/2008/Dec/90

https://bugs.php.net/bug.php?id=42862

https://bugs.php.net/bug.php?id=45151

https://bugs.php.net/bug.php?id=45722

http://www.php.net/releases/5_2_7.php

http://www.php.net/ChangeLog-5.php#5.2.7

Plugin 詳細資訊

嚴重性: High

ID: 35043

檔案名稱: php_5_2_7.nasl

版本: 1.32

類型: remote

系列: CGI abuses

已發布: 2008/12/5

已更新: 2022/4/11

風險資訊

VPR

風險因素: Medium

分數: 6.7

CVSS v2

風險因素: High

基本分數: 7.5

時間分數: 5.9

媒介: AV:N/AC:L/Au:N/C:P/I:P/A:P

時間媒介: E:POC/RL:OF/RC:C

弱點資訊

CPE: cpe:/a:php:php

必要的 KB 項目: www/PHP

可輕鬆利用: No exploit is required

修補程式發佈日期: 2008/12/4

弱點發布日期: 2008/6/19

參考資訊

CVE: CVE-2008-2371, CVE-2008-2665, CVE-2008-2666, CVE-2008-2829, CVE-2008-3658, CVE-2008-3659, CVE-2008-3660, CVE-2008-5557, CVE-2008-5624, CVE-2008-5625, CVE-2008-5658, CVE-2008-7068, CVE-2014-8626

BID: 29796, 29797, 29829, 30087, 30649, 31612, 32383, 32625, 32688, 32948, 70928

CWE: 20, 22, 119, 264