PHP < 4.4.9 多種弱點

high Nessus Plugin ID 33849

Synopsis

遠端 web 伺服器使用的 PHP 版本受到多個問題影響。

描述

根據其標題,遠端主機上安裝的 PHP 版本舊於 4.4.9。這些版本可能會受到多個安全性問題影響:

- 版本 7.7 修復的搭配 PCRE 中,存有不明問題。

- 指定特製字型時,可能會觸發 'ext/gd/gd.c' 之 'imageloadfont()' 函式中的緩衝區溢位。(CVE-2008-3658)

- 內部 'memnstr()' 函式中存有緩衝區溢位問題,其會顯示在 'explode()' 的使用者空間中。
(CVE-2008-3659)

- 檔案名稱包含 2 個點時,存有拒絕服務弱點。(CVE-2008-3660)

- Curl 延伸模組中存有 'open_basedir' 處理問題。

- '.htaccess' 中設定的 'mbstring.func_overload' 集變為全域。(CVE-2009-0754)

請注意,版本公告聲明,此將會是 PHP 4.4 系列的最後版本。

解決方案

升級至 PHP 4.4.9 版或更新版本。

另請參閱

https://www.openwall.com/lists/oss-security/2008/08/08/2

http://www.php.net/releases/4_4_9.php

http://www.php.net/ChangeLog-4.php#4.4.9

https://bugs.php.net/bug.php?id=27421

Plugin 詳細資訊

嚴重性: High

ID: 33849

檔案名稱: php_4_4_9.nasl

版本: 1.28

類型: remote

系列: CGI abuses

已發布: 2008/8/8

已更新: 2022/4/11

組態: 啟用徹底檢查

風險資訊

VPR

風險因素: Medium

分數: 5.9

CVSS v2

風險因素: High

基本分數: 7.5

時間分數: 5.9

媒介: AV:N/AC:L/Au:N/C:P/I:P/A:P

時間媒介: E:POC/RL:OF/RC:C

弱點資訊

CPE: cpe:/a:php:php

必要的 KB 項目: www/PHP

可輕鬆利用: No exploit is required

參考資訊

CVE: CVE-2007-4850, CVE-2008-3658, CVE-2008-3659, CVE-2008-3660, CVE-2009-0754

BID: 27413, 30649, 31612, 33542

SECUNIA: 31409

CWE: 20, 119, 134, 264