Samba < 3.0.30 receive_smb_raw 函式遠端緩衝區溢位

high Nessus Plugin ID 32476

Synopsis

遠端 Samba 伺服器可能受到一個緩衝區溢位弱點影響。

描述

根據其標題來判斷,遠端主機上的 Samba 伺服器版本據報在剖析在用戶端內容中接收的 SMB 封包時,會受到「lib/util_sock.c」中「eceive_smb_raw」函式的「nmbd」中一個邊界錯誤影響。攻擊者藉由傳送特製的封包至設定為本機或網域主要瀏覽器的「nmbd」伺服器,可以利用此問題造成堆積型緩衝區溢位,並以系統權限執行任意程式碼。

請注意,Nessus 尚未確實嘗試利用此問題,驗證遠端「nmbd」伺服器的組態或者判斷是否已套用修正程式。

解決方案

升級至 Samba 3.0.30 版或更新版本,或是套用專案公告中所提及的修補程式。

另請參閱

https://secuniaresearch.flexerasoftware.com/secunia_research/2008-20/advisory/

https://www.samba.org/samba/security/CVE-2008-1105.html

https://seclists.org/bugtraq/2008/May/328

Plugin 詳細資訊

嚴重性: High

ID: 32476

檔案名稱: samba_3_0_30.nasl

版本: 1.15

類型: remote

系列: Misc.

已發布: 2008/5/29

已更新: 2018/11/15

組態: 啟用 Paranoid 模式

風險資訊

VPR

風險因素: Medium

分數: 6.7

CVSS v2

風險因素: High

基本分數: 7.5

時間分數: 5.9

媒介: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

時間媒介: CVSS2#E:POC/RL:OF/RC:C

弱點資訊

CPE: cpe:2.3:a:samba:samba:*:*:*:*:*:*:*:*

必要的 KB 項目: Settings/ParanoidReport, SMB/samba, SMB/NativeLanManager

可被惡意程式利用: true

可輕鬆利用: Exploits are available

參考資訊

CVE: CVE-2008-1105

BID: 29404

CWE: 119

Secunia: 30228