PHP < 4.4.8 多種弱點

high Nessus Plugin ID 29833

語系:

Synopsis

遠端 web 伺服器使用的 PHP 版本受到多個問題影響。

描述

根據其標題,遠端主機上安裝的 PHP 版本舊於 4.4.8。這些版本可能受到數個問題影響,包括涉及 'chunk_split'、'strcspn' 和 'strspn' 函式的整數溢位,以及 'safe_mode'/'open_basedir' 繞過。

解決方案

升級至 PHP 4.4.8 版或更新版本。

另請參閱

http://www.php.net/releases/4_4_8.php

Plugin 詳細資訊

嚴重性: High

ID: 29833

檔案名稱: php_4_4_8.nasl

版本: 1.22

類型: remote

系列: CGI abuses

已發布: 2008/1/3

已更新: 2022/4/11

組態: 啟用徹底檢查

風險資訊

VPR

風險因素: Medium

分數: 6.6

CVSS v2

風險因素: High

基本分數: 7.5

時間分數: 5.9

媒介: AV:N/AC:L/Au:N/C:P/I:P/A:P

時間媒介: E:POC/RL:OF/RC:C

弱點資訊

CPE: cpe:/a:php:php

必要的 KB 項目: www/PHP

可輕鬆利用: No exploit is required

修補程式發佈日期: 2008/1/3

弱點發布日期: 2007/8/30

參考資訊

CVE: CVE-2007-3378, CVE-2007-3799, CVE-2007-3997, CVE-2007-4657, CVE-2007-4658, CVE-2008-0145, CVE-2008-2108

BID: 24661, 49631

CWE: 20, 119, 189, 264