PHP < 4.4.7 / 5.2.2 多種弱點

high Nessus Plugin ID 25159

語系:

Synopsis

遠端 Web 伺服器使用受到多個缺陷影響的 PHP 版本。

描述

根據其標題,遠端主機上安裝的 PHP 版本比 4.4.7 / 5.2.2 舊。這些版本可能受到多個問題影響,其中便包括 GD 庫中的緩衝區溢位問題。

解決方案

升級至 PHP 4.4.7 / 5.2.2 或更新版本。

另請參閱

http://www.php.net/releases/4_4_7.php

http://www.php.net/releases/5_2_2.php

Plugin 詳細資訊

嚴重性: High

ID: 25159

檔案名稱: php_4_4_7_or_5_2_2.nasl

版本: 1.39

類型: remote

系列: CGI abuses

已發布: 2007/5/4

已更新: 2022/4/11

組態: 啟用 Paranoid 模式, 啟用徹底檢查

風險資訊

VPR

風險因素: Medium

分數: 6.7

CVSS v2

風險因素: High

基本分數: 7.5

時間分數: 5.9

媒介: AV:N/AC:L/Au:N/C:P/I:P/A:P

時間媒介: E:POC/RL:OF/RC:C

弱點資訊

CPE: cpe:/a:php:php

必要的 KB 項目: www/PHP, Settings/ParanoidReport

可輕鬆利用: No exploit is required

弱點發布日期: 2007/1/29

參考資訊

CVE: CVE-2007-0455, CVE-2007-0911, CVE-2007-1001, CVE-2007-1285, CVE-2007-1375, CVE-2007-1396, CVE-2007-1399, CVE-2007-1460, CVE-2007-1461, CVE-2007-1484, CVE-2007-1521, CVE-2007-1522, CVE-2007-1582, CVE-2007-1583, CVE-2007-1709, CVE-2007-1710, CVE-2007-1717, CVE-2007-1718, CVE-2007-1864, CVE-2007-1883, CVE-2007-2509, CVE-2007-2510, CVE-2007-2511, CVE-2007-2727, CVE-2007-2748, CVE-2007-3998, CVE-2007-4670

BID: 22289, 22764, 22990, 23357, 23813, 23818, 23984, 24012

CWE: 20, 119