PHP < 4.4.5 多種弱點

high Nessus Plugin ID 24906

Synopsis

遠端 Web 伺服器使用受到多個缺陷影響的 PHP 版本。

描述

根據其標題,遠端主機上安裝的 PHP 版本舊於 4.4.5。這些版本可能會受到多個問題的影響,包括緩衝區溢位、格式字串弱點、任意程式碼執行、「safe_mode」和「open_basedir」略過,以及超全域記憶體區域。

解決方案

升級至 PHP 4.4.5 版或更新版本。

另請參閱

http://www.php.net/releases/4_4_5.php

Plugin 詳細資訊

嚴重性: High

ID: 24906

檔案名稱: php_4_4_5.nasl

版本: 1.27

類型: remote

系列: CGI abuses

已發布: 2007/4/2

已更新: 2022/4/11

組態: 啟用徹底檢查

風險資訊

VPR

風險因素: High

分數: 7.3

CVSS v2

風險因素: High

基本分數: 7.5

時間分數: 6.2

媒介: AV:N/AC:L/Au:N/C:P/I:P/A:P

時間媒介: E:F/RL:OF/RC:C

弱點資訊

CPE: cpe:/a:php:php

必要的 KB 項目: www/PHP

可輕鬆利用: No exploit is required

弱點發布日期: 2007/2/9

惡意利用途徑

Metasploit (PHP 4 unserialize() ZVAL Reference Counter Overflow (Cookie))

參考資訊

CVE: CVE-2006-4625, CVE-2007-0905, CVE-2007-0906, CVE-2007-0907, CVE-2007-0908, CVE-2007-0909, CVE-2007-0910, CVE-2007-0988, CVE-2007-1286, CVE-2007-1376, CVE-2007-1378, CVE-2007-1379, CVE-2007-1380, CVE-2007-1700, CVE-2007-1701, CVE-2007-1777, CVE-2007-1825, CVE-2007-1835, CVE-2007-1884, CVE-2007-1885, CVE-2007-1886, CVE-2007-1887, CVE-2007-1890

BID: 22496, 22805, 22806, 22833, 22862, 23119, 23120, 23169, 23219, 23233, 23234, 23235, 23236

CWE: 20, 399