Samba < 3.0.24 多個瑕疵

high Nessus Plugin ID 24685

Synopsis

遠端 Samba 伺服器受到數個可造成遠端程式碼執行的弱點影響

描述

根據其版本號碼來判斷,遠端 Samba 伺服器受到多個瑕疵影響:

- 經驗證的攻擊者若傳送大量會造成 smbd 程序中發生無限迴圈的 CIFS 工作階段要求,可以引發拒絕服務問題,進而利用 CPU 資源並拒絕合法使用者存取;

- 一個遠端格式字串弱點,具有遠端共用寫入存取權的攻擊者可利用此弱點,將格式錯誤的要求傳送至遠端服務 (此問題只會影響 afsacl.so VFS 模組載入時共用 AFS 檔案系統的安裝版本)

- 一個遠端緩衝區溢位弱點,會影響遠端 winbindd 精靈的 NSS 查閱功能

解決方案

升級至 Samba 3.0.24 或更新版本

Plugin 詳細資訊

嚴重性: High

ID: 24685

檔案名稱: samba_3_0_24.nasl

版本: 1.17

類型: remote

系列: Misc.

已發布: 2007/2/22

已更新: 2018/7/27

組態: 啟用 Paranoid 模式

風險資訊

VPR

風險因素: Medium

分數: 5.8

CVSS v2

風險因素: High

基本分數: 7.5

時間分數: 5.5

媒介: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

時間媒介: CVSS2#E:U/RL:OF/RC:C

弱點資訊

CPE: cpe:2.3:a:samba:samba:*:*:*:*:*:*:*:*

必要的 KB 項目: Settings/ParanoidReport, SMB/NativeLanManager

可輕鬆利用: No known exploits are available

弱點發布日期: 2007/2/5

參考資訊

CVE: CVE-2007-0452, CVE-2007-0453, CVE-2007-0454

BID: 22395, 22410, 22403