PHP < 4.4.3 / 5.1.4 多種弱點

high Nessus Plugin ID 22268

Synopsis

遠端 Web 伺服器使用受到多個缺陷影響的 PHP 版本。

描述

根據其標題,遠端主機上安裝的 PHP 版本比 4.4.3 / 5.1.4 舊。這些版本可能會受到一些問題的影響,包括緩衝區溢位、堆積損毀,以及變數可能用來呼叫「unset()」的瑕疵。

解決方案

升級至 PHP 4.4.3 / 5.1.4 版或更新版本。

另請參閱

http://www.nessus.org/u?a7553cd8

http://www.nessus.org/u?ccaf872d

https://www.securityfocus.com/archive/1/archive/1/442437/100/0/threaded

http://us3.php.net/releases/4_4_3.php

http://us3.php.net/releases/5_1_3.php

http://www.php.net/release_5_1_4.php

Plugin 詳細資訊

嚴重性: High

ID: 22268

檔案名稱: php_4_4_3.nasl

版本: 1.26

類型: remote

系列: CGI abuses

已發布: 2006/8/25

已更新: 2022/4/11

組態: 啟用徹底檢查

風險資訊

VPR

風險因素: Medium

分數: 6

CVSS v2

風險因素: High

基本分數: 9.3

時間分數: 7.3

媒介: AV:N/AC:M/Au:N/C:C/I:C/A:C

時間媒介: E:POC/RL:OF/RC:C

弱點資訊

CPE: cpe:/a:php:php

必要的 KB 項目: www/PHP

可輕鬆利用: No exploit is required

修補程式發佈日期: 2006/8/3

弱點發布日期: 2006/3/28

參考資訊

CVE: CVE-2006-0996, CVE-2006-1490, CVE-2006-1494, CVE-2006-1608, CVE-2006-1990, CVE-2006-1991, CVE-2006-2563, CVE-2006-2660, CVE-2006-3011, CVE-2006-3016, CVE-2006-3017, CVE-2006-3018, CVE-2006-4433

BID: 17296, 17362, 17439, 17843, 18116, 18645, 49634

CWE: 79