Amazon Linux 2:python3 (ALAS-2024-2541)

high Nessus Plugin ID 197105

概要

遠端 Amazon Linux 2 主機缺少安全性更新。

說明

遠端主機上安裝的 python3 版本是 3.7.16-1 之前版本。因此,會受到 ALAS2-2024-2541 公告中提及的一個弱點影響。

- 在 CPython 的 `tempfile.TemporaryDirectory` 類別中發現一個問題,此問題會影響 3.12.1、3.11.7、3.10.13、3.9.18、3.8.18 及更舊版本。tempfile.TemporaryDirectory 類別會在清理權限相關錯誤期間解除參照符號連結。這表示可執行特權程式的使用者在某些情況下,可能修改符號連結所參照之檔案的權限。
(CVE-2023-6597)

請注意,Nessus 並未測試此問題,而是僅依據應用程式自我報告的版本號碼作出判斷。

解決方案

執行「yum update python3」以更新系統。

另請參閱

https://alas.aws.amazon.com/AL2/ALAS-2024-2541.html

https://alas.aws.amazon.com/cve/html/CVE-2023-6597.html

https://alas.aws.amazon.com/faqs.html

Plugin 詳細資訊

嚴重性: High

ID: 197105

檔案名稱: al2_ALAS-2024-2541.nasl

版本: 1.0

類型: local

代理程式: unix

已發布: 2024/5/15

已更新: 2024/5/15

支援的感應器: Agentless Assessment, Frictionless Assessment Agent, Frictionless Assessment AWS, Nessus Agent, Nessus

風險資訊

VPR

風險因素: High

分數: 7.9

CVSS v2

風險因素: High

基本分數: 7.2

時間分數: 5.3

媒介: CVSS2#AV:L/AC:L/Au:N/C:C/I:C/A:C

CVSS 評分資料來源: CVE-2023-6597

CVSS v3

風險因素: High

基本分數: 7.8

時間分數: 6.8

媒介: CVSS:3.0/AV:L/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:N

時間媒介: CVSS:3.0/E:U/RL:O/RC:C

弱點資訊

CPE: p-cpe:/a:amazon:linux:python3, p-cpe:/a:amazon:linux:python3-test, p-cpe:/a:amazon:linux:python3-devel, p-cpe:/a:amazon:linux:python3-debuginfo, p-cpe:/a:amazon:linux:python3-debug, cpe:/o:amazon:linux:2, p-cpe:/a:amazon:linux:python3-tools, p-cpe:/a:amazon:linux:python3-libs, p-cpe:/a:amazon:linux:python3-tkinter

必要的 KB 項目: Host/local_checks_enabled, Host/AmazonLinux/release, Host/AmazonLinux/rpm-list

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2024/5/9

弱點發布日期: 2024/3/19

參考資訊

CVE: CVE-2023-6597