Amazon Linux 2:curl (ALAS-2024-2526)

low Nessus Plugin ID 194866

概要

遠端 Amazon Linux 2 主機缺少安全性更新。

說明

遠端主機上安裝的 curl 版本為早於 8.3.0-1 的版本。因此,會受到 ALAS2-2024-2526 公告中所提及的多個弱點影響。

- 當通訊協定選取參數選項停用所有通訊協定而不新增任何通訊協定時,由於移除通訊協定的邏輯錯誤,一組預設的通訊協定會保留在允許的設定中。下列命令會使用已明確停用的純文字通訊協定,對 curl.se 執行要求。curl --proto -all、-http http://curl.se 只有在所選通訊協定集停用了整組可用通訊協定時,才會出現此缺陷,而這組通訊協定本身就是沒有實際用途的命令,因此不太可能在實際情況中發生。因此,curl 安全團隊已將此評估為低嚴重性錯誤。(CVE-2024-2004)

- 當應用程式告知 libcurl 它想要允許 HTTP/2 伺服器推送,且針對推送接收的標頭數量超過允許的上限 (1000) 時,libcurl 會中止伺服器推送。中止時,libcurl 意外未釋放所有先前配置的標頭,而是洩漏了記憶體。
此外,這種錯誤條件會失敗,且無任何訊息,因此應用程式不容易檢測到。
(CVE-2024-2398)

請注意,Nessus 並未測試這些問題,而是僅依據應用程式自我報告的版本號碼作出判斷。

解決方案

執行「yum update curl」以更新系統。

另請參閱

https://alas.aws.amazon.com/AL2/ALAS-2024-2526.html

https://alas.aws.amazon.com/cve/html/CVE-2024-2004.html

https://alas.aws.amazon.com/cve/html/CVE-2024-2398.html

https://alas.aws.amazon.com/faqs.html

Plugin 詳細資訊

嚴重性: Low

ID: 194866

檔案名稱: al2_ALAS-2024-2526.nasl

版本: 1.0

類型: local

代理程式: unix

已發布: 2024/4/30

已更新: 2024/4/30

支援的感應器: Frictionless Assessment AWS, Frictionless Assessment Agent, Nessus Agent, Agentless Assessment, Nessus

風險資訊

VPR

風險因素: Medium

分數: 4.4

CVSS v2

風險因素: Medium

基本分數: 4

時間分數: 3

媒介: CVSS2#AV:N/AC:L/Au:S/C:P/I:N/A:N

CVSS 評分資料來源: CVE-2024-2004

CVSS v3

風險因素: Low

基本分數: 3.5

時間分數: 3.1

媒介: CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:N/A:N

時間媒介: CVSS:3.0/E:U/RL:O/RC:C

弱點資訊

CPE: p-cpe:/a:amazon:linux:curl, p-cpe:/a:amazon:linux:curl-debuginfo, p-cpe:/a:amazon:linux:libcurl, p-cpe:/a:amazon:linux:libcurl-devel, cpe:/o:amazon:linux:2

必要的 KB 項目: Host/local_checks_enabled, Host/AmazonLinux/release, Host/AmazonLinux/rpm-list

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2024/4/24

弱點發布日期: 2024/3/27

參考資訊

CVE: CVE-2024-2004, CVE-2024-2398

IAVA: 2024-A-0185