Amazon Linux 2:httpd (ALAS-2024-2532)

high Nessus Plugin ID 194861

概要

遠端 Amazon Linux 2 主機缺少安全性更新。

說明

遠端主機上安裝的 httpd 版本為早於 2.4.59-1 的版本。因此,會受到 ALAS2-2024-2532 公告中所提及的多個弱點影響。

- Apache 核心中的錯誤輸入驗證允許惡意或可利用的後端/內容產生器分割 HTTP 回應。此問題會影響 2.4.58 及之前的 Apache HTTP Server。(CVE-2023-38709)

- Apache HTTP Server 的多個模組包含 HTTP 回應分割弱點,攻擊者可藉此將惡意回應標頭插入後端應用程式,進而造成 HTTP 非同步攻擊。建議使用者升級至已修正此問題 2.4.59 版。(CVE-2024-24795)

請注意,Nessus 並未測試這些問題,而是僅依據應用程式自我報告的版本號碼作出判斷。

解決方案

執行「yum update httpd」以更新系統。

另請參閱

https://alas.aws.amazon.com/AL2/ALAS-2024-2532.html

https://alas.aws.amazon.com/cve/html/CVE-2023-38709.html

https://alas.aws.amazon.com/cve/html/CVE-2024-24795.html

https://alas.aws.amazon.com/faqs.html

Plugin 詳細資訊

嚴重性: High

ID: 194861

檔案名稱: al2_ALAS-2024-2532.nasl

版本: 1.0

類型: local

代理程式: unix

已發布: 2024/4/30

已更新: 2024/4/30

支援的感應器: Agentless Assessment, Frictionless Assessment Agent, Frictionless Assessment AWS, Nessus Agent, Nessus

風險資訊

VPR

風險因素: Medium

分數: 6.0

CVSS v2

風險因素: Medium

基本分數: 5

時間分數: 3.7

媒介: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

CVSS 評分資料來源: CVE-2024-24795

CVSS v3

風險因素: High

基本分數: 7.5

時間分數: 6.5

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

時間媒介: CVSS:3.0/E:U/RL:O/RC:C

弱點資訊

CPE: p-cpe:/a:amazon:linux:httpd-tools, p-cpe:/a:amazon:linux:mod_ldap, p-cpe:/a:amazon:linux:mod_proxy_html, p-cpe:/a:amazon:linux:mod_session, p-cpe:/a:amazon:linux:mod_ssl, cpe:/o:amazon:linux:2, p-cpe:/a:amazon:linux:httpd-devel, p-cpe:/a:amazon:linux:httpd-debuginfo, p-cpe:/a:amazon:linux:mod_md, p-cpe:/a:amazon:linux:httpd, p-cpe:/a:amazon:linux:httpd-manual, p-cpe:/a:amazon:linux:httpd-filesystem

必要的 KB 項目: Host/local_checks_enabled, Host/AmazonLinux/release, Host/AmazonLinux/rpm-list

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2024/4/24

弱點發布日期: 2024/4/4

參考資訊

CVE: CVE-2023-38709, CVE-2024-24795