Amazon Linux AMI:glibc (ALAS-2024-1930)

high Nessus Plugin ID 194723

概要

遠端 Amazon Linux AMI 主機缺少安全性更新。

說明

遠端主機上安裝的 glibc 版本是 2.17-324.190 之前版本。因此,會受到 ALAS-2024-1930 公告中提及的一個弱點影響。

- 將字串轉換為 ISO-2022-CN-EXT 字元集時,GNU C Library 2.39 和更舊版本中的 iconv() 函式可能會造成傳遞給它的輸出緩衝區溢位最多 4 個位元組,攻擊者可利用此問題造成應用程式當機或相鄰變數被覆寫。(CVE-2024-2961)

請注意,Nessus 並未測試此問題,而是僅依據應用程式自我報告的版本號碼作出判斷。

解決方案

執行「yum update glibc」以更新系統。

另請參閱

https://alas.aws.amazon.com/ALAS-2024-1930.html

https://alas.aws.amazon.com/cve/html/CVE-2024-2961.html

https://alas.aws.amazon.com/faqs.html

Plugin 詳細資訊

嚴重性: High

ID: 194723

檔案名稱: ala_ALAS-2024-1930.nasl

版本: 1.0

類型: local

代理程式: unix

已發布: 2024/4/29

已更新: 2024/4/29

支援的感應器: Agentless Assessment, Frictionless Assessment Agent, Frictionless Assessment AWS, Nessus Agent, Nessus

風險資訊

VPR

風險因素: Critical

分數: 9.4

CVSS v2

風險因素: High

基本分數: 8.5

時間分數: 6.3

媒介: CVSS2#AV:N/AC:L/Au:N/C:N/I:P/A:C

CVSS 評分資料來源: CVE-2024-2961

CVSS v3

風險因素: High

基本分數: 8.2

時間分數: 7.1

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:H

時間媒介: CVSS:3.0/E:U/RL:O/RC:C

弱點資訊

CPE: p-cpe:/a:amazon:linux:glibc-static, p-cpe:/a:amazon:linux:glibc-devel, p-cpe:/a:amazon:linux:glibc-common, p-cpe:/a:amazon:linux:glibc, p-cpe:/a:amazon:linux:glibc-utils, p-cpe:/a:amazon:linux:glibc-debuginfo, p-cpe:/a:amazon:linux:glibc-headers, p-cpe:/a:amazon:linux:glibc-debuginfo-common, cpe:/o:amazon:linux, p-cpe:/a:amazon:linux:nscd

必要的 KB 項目: Host/AmazonLinux/rpm-list, Host/local_checks_enabled, Host/AmazonLinux/release

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2024/4/25

弱點發布日期: 2024/4/17

參考資訊

CVE: CVE-2024-2961