CentOS 8:libtiff (CESA-2023: 0095)

medium Nessus Plugin ID 190181

概要

遠端 CentOS 主機缺少一個或多個安全性更新。

說明

遠端 CentOS Linux 8 主機上安裝的套件受到 CESA-2023: 0095 公告中提及的多個弱點影響。

- libtiff 4.4.0 版 tiffcrop 中的除以零錯誤允許攻擊者透過建構的 tiff 檔案造成拒絕服務。對於使用原始碼編譯 libtiff 的使用者,可透過 commit f3a5e010 取得修正程式。
(CVE-2022-2056, CVE-2022-2057, CVE-2022-2058)

- 在 libtiff 4.4.0rc1 中 tiffcrop.c:8839 的 rotateImage() 中發現重複釋放或損毀問題 (CVE-2022-2519)

- 在 libtiff 4.4.0rc1 中發現一個瑕疵。tiffcrop.c:8621 的 rotateImage() 中存在 sysmalloc 宣告失敗弱點,讀取特製的輸入時,此弱點可造成程式損毀。(CVE-2022-2520)

- 在 libtiff 4.4.0rc1 中,由 tiffcrop.c:2522 呼叫的 tif_close.c:131 的 TIFFClose() 中存在無效的指標釋放作業,處理特製輸入時可造成程式損毀和拒絕服務。(CVE-2022-2521)

- libtiff 的 tiffcrop 公用程式有一個 uint32_t 反向溢位,可導致超出邊界讀取和寫入。向 tiffcrop 提供建構檔案的攻擊者 (可能透過誘騙使用者使用特定參數在該檔案上執行 tiffcrop) 可造成當機,在某些情況下,還可造成進一步惡意利用。(CVE-2022-2867)

- libtiff 的 tiffcrop 公用程式有一個不當輸入驗證缺陷,如果攻擊者能夠向 tiffcrop 提供建構的檔案,則可導致超出邊界讀取並最終造成當機。(CVE-2022-2868)

- libtiff 的 tiffcrop 工具有一個 uint32_t 反向溢位,會導致 extractContigSamples8bits 常式發生超出邊界讀取和寫入。向 tiffcrop 提供建構檔案的攻擊者可透過誘騙使用者使用 tiffcrop 開啟建構檔案來觸發此缺陷。觸發此缺陷可造成當機或可能進一步惡意利用。(CVE-2022-2869)

- 在 LibTIFF 4.4.0 中,tools/tiffcrop.c:6905 的 extractImageSection 中存在超出邊界讀取弱點,此弱點允許攻擊者透過特製的 tiff 檔案造成拒絕服務。對於使用原始碼編譯 libtiff 的使用者,可透過 commit 48d6ece8 取得此問題的修正程式。(CVE-2022-2953)

請注意,Nessus 並未測試這些問題,而是僅依據應用程式自我報告的版本號碼作出判斷。

解決方案

更新受影響的 libtiff、libtiff-devel 和/或 libtiff-tools 套件。

另請參閱

https://access.redhat.com/errata/RHSA-2023:0095

Plugin 詳細資訊

嚴重性: Medium

ID: 190181

檔案名稱: centos8_RHSA-2023-0095.nasl

版本: 1.0

類型: local

代理程式: unix

已發布: 2024/2/8

已更新: 2024/2/8

支援的感應器: Frictionless Assessment AWS, Frictionless Assessment Azure, Frictionless Assessment Agent, Agentless Assessment, Nessus

風險資訊

VPR

風險因素: Medium

分數: 4.4

CVSS v2

風險因素: Medium

基本分數: 4.3

時間分數: 3.4

媒介: CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:P

CVSS 評分資料來源: CVE-2022-2058

CVSS v3

風險因素: Medium

基本分數: 6.5

時間分數: 5.9

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H

時間媒介: CVSS:3.0/E:P/RL:O/RC:C

CVSS 評分資料來源: CVE-2022-2521

弱點資訊

CPE: cpe:/o:centos:centos:8-stream, p-cpe:/a:centos:centos:libtiff, p-cpe:/a:centos:centos:libtiff-devel, p-cpe:/a:centos:centos:libtiff-tools

必要的 KB 項目: Host/local_checks_enabled, Host/cpu, Host/CentOS/release, Host/CentOS/rpm-list

可被惡意程式利用: true

可輕鬆利用: Exploits are available

修補程式發佈日期: 2023/1/12

弱點發布日期: 2022/6/28

參考資訊

CVE: CVE-2022-2056, CVE-2022-2057, CVE-2022-2058, CVE-2022-2519, CVE-2022-2520, CVE-2022-2521, CVE-2022-2867, CVE-2022-2868, CVE-2022-2869, CVE-2022-2953

RHSA: 2023:0095