Ubuntu 16.04 ESM / 18.04 ESM / 20.04 LTS / 22.04 LTS / 23.04 / 23.10 : ZooKeeper 弱點 (USN-6559-1)

critical Nessus Plugin ID 189088

概要

遠端 Ubuntu 主機缺少一個或多個安全性更新。

說明

遠端 Ubuntu 16.04 ESM / 18.04 ESM / 20.04 LTS / 22.04 LTS / 23.04 / 23.10 主機上安裝的多個套件受到 USN-6559-1 公告中提及的多個弱點影響。

- 在 1.0.0 到 3.4.13 以及 3.5.0-alpha 到 3.5.4-beta 版的 Apache ZooKeeper 中存在一個問題。ZooKeeper 的 getACL() 命令在擷取所要求節點的 ACL 時不會檢查任何權限,並以純文字字串的形式傳回 ACL Id 欄位中包含的所有資訊。DigestAuthenticationProvider 以用於使用者驗證的雜湊值使 Id 欄位過載。因此,如果摘要式驗證正在使用中,則 getACL() 要求會向未經驗證或無權限的使用者洩漏不使用 salt 的雜湊值。(CVE-2019-0201)

- 透過 Apache ZooKeeper 中使用者控制的金鑰弱點造成的授權繞過。如果在 ZooKeeper 中啟用 SASL Quorum Peer 驗證 (quorum.auth.enableSasl=true),則會透過驗證 SASL 驗證 ID 中的執行個體部分是否列在 zoo.cfg 伺服器清單中來完成授權。SASL 驗證 ID 中的執行個體部分是選用的,若遺漏,則會略過授權檢查,例如「[email protected]」。因此,任意端點可加入叢集,並開始將偽造的變更傳播至 leader,實質上為其提供資料樹狀結構的完整讀寫存取權。依預設,不啟用 Quorum Peer 驗證。建議使用者升級至 3.9.1、3.8.3、3.7.2 版,即可修正此問題。或者,確保 ensemble 選擇方式/quorum 通訊方式受到防火牆保護,以便緩解這一問題。如需有關正確管理叢集的詳細資訊,請參閱這份文件。(CVE-2023-44981)

請注意,Nessus 並未測試這些問題,而是僅依據應用程式自我報告的版本號碼作出判斷。

解決方案

更新受影響的套件。

另請參閱

https://ubuntu.com/security/notices/USN-6559-1

Plugin 詳細資訊

嚴重性: Critical

ID: 189088

檔案名稱: ubuntu_USN-6559-1.nasl

版本: 1.1

類型: local

代理程式: unix

已發布: 2024/1/16

已更新: 2024/3/21

支援的感應器: Frictionless Assessment AWS, Frictionless Assessment Azure, Frictionless Assessment Agent, Nessus Agent, Agentless Assessment, Nessus

風險資訊

VPR

風險因素: Medium

分數: 5.2

CVSS v2

風險因素: Medium

基本分數: 4.3

時間分數: 3.2

媒介: CVSS2#AV:N/AC:M/Au:N/C:P/I:N/A:N

CVSS 評分資料來源: CVE-2019-0201

CVSS v3

風險因素: Critical

基本分數: 9.1

時間分數: 7.9

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N

時間媒介: CVSS:3.0/E:U/RL:O/RC:C

CVSS 評分資料來源: CVE-2023-44981

弱點資訊

CPE: cpe:/o:canonical:ubuntu_linux:16.04:-:esm, cpe:/o:canonical:ubuntu_linux:18.04:-:esm, cpe:/o:canonical:ubuntu_linux:20.04:-:lts, cpe:/o:canonical:ubuntu_linux:22.04:-:lts, cpe:/o:canonical:ubuntu_linux:23.04, cpe:/o:canonical:ubuntu_linux:23.10, p-cpe:/a:canonical:ubuntu_linux:libzookeeper-java, p-cpe:/a:canonical:ubuntu_linux:libzookeeper-mt-dev, p-cpe:/a:canonical:ubuntu_linux:libzookeeper-mt2, p-cpe:/a:canonical:ubuntu_linux:libzookeeper-st-dev, p-cpe:/a:canonical:ubuntu_linux:libzookeeper-st2, p-cpe:/a:canonical:ubuntu_linux:libzookeeper2, p-cpe:/a:canonical:ubuntu_linux:python-zookeeper, p-cpe:/a:canonical:ubuntu_linux:python3-zookeeper, p-cpe:/a:canonical:ubuntu_linux:zookeeper, p-cpe:/a:canonical:ubuntu_linux:zookeeper-bin, p-cpe:/a:canonical:ubuntu_linux:zookeeperd

必要的 KB 項目: Host/cpu, Host/Debian/dpkg-l, Host/Ubuntu, Host/Ubuntu/release

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2024/1/16

弱點發布日期: 2019/5/20

參考資訊

CVE: CVE-2019-0201, CVE-2023-44981

IAVB: 2019-B-0041-S, 2023-B-0082-S

USN: 6559-1