Oracle Linux 8:fence-agents (ELSA-2024-0133)

critical Nessus Plugin ID 187980

概要

遠端 Oracle Linux 主機缺少一個或多個安全性更新。

說明

遠端 Oracle Linux 8 主機中安裝的套件受到 ELSA-2024-0133 公告中提及的多個弱點影響。

- urllib3 是適用於 Python 的人性化 HTTP 用戶端程式庫。urllib3 並未特殊處理 `Cookie` HTTP 標頭,或提供任何協助程式來管理 HTTP 上的 Cookie,這是使用者的責任。
但是,如果使用者未明確停用重新導向,該使用者或可指定 `Cookie` 標頭,並透過 HTTP 重新導向至不同來源,進而在不知情的情況下泄漏資訊。此問題已在 urllib3 1.26.17 版或 2.0.5 版中修正。(CVE-2023-43804)

- Certifi 是精選的 Root 憑證集合,用於在驗證 TLS 主機身分的同時驗證 SSL 憑證的可靠性。2023.07.22 版之前的 Certifi 可辨識 e-Tugra root 憑證。e-Tugra 的 Root 憑證須接受系統報告安全性問題時提示的調查。Certifi 2023.07.22 從 Root 存放區移除了 e-Tugra 中的 Root 憑證。(CVE-2023-37920)

請注意,Nessus 並未測試這些問題,而是僅依據應用程式自我報告的版本號碼作出判斷。

解決方案

更新受影響的套件。

另請參閱

https://linux.oracle.com/errata/ELSA-2024-0133.html

Plugin 詳細資訊

嚴重性: Critical

ID: 187980

檔案名稱: oraclelinux_ELSA-2024-0133.nasl

版本: 1.0

類型: local

代理程式: unix

已發布: 2024/1/12

已更新: 2024/1/12

支援的感應器: Frictionless Assessment Agent, Nessus Agent, Nessus

風險資訊

VPR

風險因素: Medium

分數: 6.0

CVSS v2

風險因素: Critical

基本分數: 10

時間分數: 7.4

媒介: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

CVSS 評分資料來源: CVE-2023-37920

CVSS v3

風險因素: Critical

基本分數: 9.8

時間分數: 8.5

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

時間媒介: CVSS:3.0/E:U/RL:O/RC:C

弱點資訊

CPE: p-cpe:/a:oracle:linux:fence-agents-emerson, p-cpe:/a:oracle:linux:fence-agents-eps, p-cpe:/a:oracle:linux:fence-agents-heuristics-ping, p-cpe:/a:oracle:linux:fence-agents-hpblade, p-cpe:/a:oracle:linux:fence-agents-ibm-powervs, p-cpe:/a:oracle:linux:fence-agents-ibm-vpc, p-cpe:/a:oracle:linux:fence-agents-ibmblade, p-cpe:/a:oracle:linux:fence-agents-ifmib, p-cpe:/a:oracle:linux:fence-agents-ilo-moonshot, p-cpe:/a:oracle:linux:fence-agents-ilo-mp, p-cpe:/a:oracle:linux:fence-agents-ilo-ssh, p-cpe:/a:oracle:linux:fence-agents-ilo2, p-cpe:/a:oracle:linux:fence-agents-intelmodular, p-cpe:/a:oracle:linux:fence-agents-ipdu, p-cpe:/a:oracle:linux:fence-agents-ipmilan, p-cpe:/a:oracle:linux:fence-agents-kdump, p-cpe:/a:oracle:linux:fence-agents-kubevirt, p-cpe:/a:oracle:linux:fence-agents-lpar, p-cpe:/a:oracle:linux:fence-agents-mpath, p-cpe:/a:oracle:linux:fence-agents-redfish, cpe:/a:oracle:linux:8::appstream, cpe:/o:oracle:linux:8, p-cpe:/a:oracle:linux:fence-agents-all, p-cpe:/a:oracle:linux:fence-agents-amt-ws, p-cpe:/a:oracle:linux:fence-agents-apc, p-cpe:/a:oracle:linux:fence-agents-apc-snmp, p-cpe:/a:oracle:linux:fence-agents-bladecenter, p-cpe:/a:oracle:linux:fence-agents-brocade, p-cpe:/a:oracle:linux:fence-agents-cisco-mds, p-cpe:/a:oracle:linux:fence-agents-cisco-ucs, p-cpe:/a:oracle:linux:fence-agents-common, p-cpe:/a:oracle:linux:fence-agents-compute, p-cpe:/a:oracle:linux:fence-agents-drac5, p-cpe:/a:oracle:linux:fence-agents-eaton-snmp, p-cpe:/a:oracle:linux:fence-agents-rhevm, p-cpe:/a:oracle:linux:fence-agents-rsa, p-cpe:/a:oracle:linux:fence-agents-rsb, p-cpe:/a:oracle:linux:fence-agents-sbd, p-cpe:/a:oracle:linux:fence-agents-scsi, p-cpe:/a:oracle:linux:fence-agents-virsh, p-cpe:/a:oracle:linux:fence-agents-vmware-rest, p-cpe:/a:oracle:linux:fence-agents-vmware-soap, p-cpe:/a:oracle:linux:fence-agents-wti

必要的 KB 項目: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list, Host/OracleLinux

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2024/1/11

弱點發布日期: 2023/7/25

參考資訊

CVE: CVE-2023-37920, CVE-2023-43804