Oracle Linux 9:tigervnc (ELSA-2024-0010)

high Nessus Plugin ID 187615

概要

遠端 Oracle Linux 主機缺少一個或多個安全性更新。

說明

遠端 Oracle Linux 9 主機中安裝的套件受到 ELSA-2024-0010 公告中提及的多個弱點影響。

- 在 xorg-x11-server 中發現一個超出邊界寫入缺陷。發生此問題的原因是,在 Xi/xiproperty.c 的 XIChangeDeviceProperty 函式中,以及 randr/rrproperty.c 的 RRChangeOutputProperty 函式中,複製儲存在堆積中的資料時,未正確計算緩衝區位移,進而可能導致權限提升或拒絕服務。(CVE-2023-5367)

- 在 xorg-server 中發現一個缺陷。查詢或變更 XKB 按鈕動作 (例如從觸控板移至滑鼠) 可導致超出邊界記憶體讀取和寫入。在涉及 X11 轉送的情況下,這可能允許本機權限提升或可能的遠端程式碼執行。 (CVE-2023-6377)

- 在 xorg-server 中發現一個缺陷。對 RRChangeProviderProperty 或 RRChangeOutputProperty 的特製要求可觸發整數溢位,進而可能導致洩漏敏感資訊。 (CVE-2023-6478)

請注意,Nessus 並未測試這些問題,而是僅依據應用程式自我報告的版本號碼作出判斷。

解決方案

更新受影響的套件。

另請參閱

https://linux.oracle.com/errata/ELSA-2024-0010.html

Plugin 詳細資訊

嚴重性: High

ID: 187615

檔案名稱: oraclelinux_ELSA-2024-0010.nasl

版本: 1.0

類型: local

代理程式: unix

已發布: 2024/1/3

已更新: 2024/1/3

支援的感應器: Frictionless Assessment Agent, Nessus Agent, Nessus

風險資訊

VPR

風險因素: Medium

分數: 6.7

CVSS v2

風險因素: High

基本分數: 7.8

時間分數: 5.8

媒介: CVSS2#AV:N/AC:L/Au:N/C:C/I:N/A:N

CVSS 評分資料來源: CVE-2023-6478

CVSS v3

風險因素: High

基本分數: 7.8

時間分數: 6.8

媒介: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

時間媒介: CVSS:3.0/E:U/RL:O/RC:C

CVSS 評分資料來源: CVE-2023-6377

弱點資訊

CPE: cpe:/a:oracle:linux:9::appstream, cpe:/o:oracle:linux:9, p-cpe:/a:oracle:linux:tigervnc, p-cpe:/a:oracle:linux:tigervnc-icons, p-cpe:/a:oracle:linux:tigervnc-license, p-cpe:/a:oracle:linux:tigervnc-selinux, p-cpe:/a:oracle:linux:tigervnc-server, p-cpe:/a:oracle:linux:tigervnc-server-minimal, p-cpe:/a:oracle:linux:tigervnc-server-module

必要的 KB 項目: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list, Host/OracleLinux

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2024/1/3

弱點發布日期: 2023/10/25

參考資訊

CVE: CVE-2023-5367, CVE-2023-6377, CVE-2023-6478