Apache ActiveMQ RCE (CVE-2023-46604)

critical Nessus Plugin ID 186650

概要

遠端主機所包含的服務受到遠端程式碼執行弱點影響。

說明

遠端主機包含的 Apache ActiveMQ 版本低於 5.15.16、5.16.7、5.17.6 或 5.18.3。因此會受到遠端程式碼執行弱點影響。遠端攻擊者可利用此弱點,從任意 URL 載入所選的惡意 XML 並執行遠端程式碼。

解決方案

升級至 Apache ActiveMQ 5.15.16、5.16.7、5.17.6、5.18.3 或更新版本。

另請參閱

http://www.nessus.org/u?023610ba

Plugin 詳細資訊

嚴重性: Critical

ID: 186650

檔案名稱: activemq_CVE-2023-46604.nbin

版本: 1.19

類型: remote

系列: Misc.

已發布: 2023/12/7

已更新: 2024/7/17

支援的感應器: Nessus

Enable CGI Scanning: true

風險資訊

VPR

風險因素: Critical

分數: 9.0

CVSS v2

風險因素: Critical

基本分數: 10

時間分數: 8.3

媒介: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

CVSS 評分資料來源: CVE-2023-46604

CVSS v3

風險因素: Critical

基本分數: 9.8

時間分數: 9.1

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

時間媒介: CVSS:3.0/E:F/RL:O/RC:C

弱點資訊

CPE: cpe:/a:apache:activemq

必要的 KB 項目: installed_sw/Apache ActiveMQ

排除在外的 KB 項目: Settings/disable_cgi_scanning

可被惡意程式利用: true

可輕鬆利用: Exploits are available

由 Nessus 利用: true

修補程式發佈日期: 2023/10/27

弱點發布日期: 2023/10/27

CISA 已知遭惡意利用弱點到期日: 2023/11/23

可惡意利用

Core Impact

Metasploit (Apache ActiveMQ Unauthenticated Remote Code Execution)

參考資訊

CVE: CVE-2023-46604