Wireshark 4.0.x < 4.0.11 多個弱點

medium Nessus Plugin ID 185776

概要

遠端 Windows 主機上安裝的應用程式受到多個弱點影響。

說明

遠端 Windows 主機上安裝的 Wireshark 為 4.0.11 之前版本。因此,它受到 wireshark-4.0.11 公告中提及的多個弱點影響。

- SSH 解剖器可能會當機。藉由將格式錯誤的封包插入連線,或引誘使用者讀取格式錯誤的封包追蹤檔案,可能造成 Wireshark 損毀或過度消耗 CPU 資源。(wireshark-bug-19369)

- NetScreen 檔案剖析器可能損毀。攻擊者可能利用此弱點,將格式錯誤的封包插入連線,或設法讓某人讀取格式錯誤的封包跟踪檔案,進而造成 Wireshark 當機。(wireshark-bug-19404)

請注意,Nessus 並未測試這些問題,而是僅依據應用程式自我報告的版本號碼作出判斷。

解決方案

升級版本至 Wireshark 4.0.11 或更新版本。

另請參閱

https://www.wireshark.org/security/wnpa-sec-2023-28

https://www.wireshark.org/security/wnpa-sec-2023-29

https://gitlab.com/wireshark/wireshark/-/issues/19404

https://www.wireshark.org/docs/relnotes/wireshark-4.0.11.html

https://gitlab.com/wireshark/wireshark/-/issues/19369

Plugin 詳細資訊

嚴重性: Medium

ID: 185776

檔案名稱: wireshark_4_0_11.nasl

版本: 1.5

類型: local

代理程式: windows

系列: Windows

已發布: 2023/11/15

已更新: 2024/1/12

支援的感應器: Frictionless Assessment Agent, Nessus Agent, Nessus

風險資訊

VPR

風險因素: Medium

分數: 6.7

CVSS v2

風險因素: High

基本分數: 7.8

時間分數: 5.8

媒介: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:C

CVSS 評分資料來源: CVE-2023-6174

CVSS v3

風險因素: Medium

基本分數: 6.5

時間分數: 5.7

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H

時間媒介: CVSS:3.0/E:U/RL:O/RC:C

弱點資訊

CPE: cpe:/a:wireshark:wireshark

必要的 KB 項目: SMB/Registry/Enumerated, installed_sw/Wireshark

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2023/11/15

弱點發布日期: 2023/11/15

參考資訊

CVE: CVE-2023-6174, CVE-2023-6175

IAVB: 2023-B-0091-S