Amazon Linux AMI:tomcat8 (ALAS-2023-1868)

medium Nessus Plugin ID 183405

概要

遠端 Amazon Linux AMI 主機缺少安全性更新。

說明

遠端主機上安裝的 tomcat8 版本早於 8.5.94-1.95。因此,它受到 ALAS-2023-1868 公告中所提及的多個弱點影響。

- Apache Tomcat 中存在不完整的清理弱點。在 Apache Tomcat 11.0.0-M1 至 11.0.0-M11、10.1.0-M1 至 10.1.13、9.0.0-M1 至 9.0.80 以及 8.5.0 至 8.5.93 版中,回收各種內部物件時存在一個錯誤,其可造成 Tomcat 略過部分回收處理程序,進而導致資訊從目前的要求/回應洩漏至下一個要求/回應。建議使用者升級至 11.0.0-M12 之後的版本、10.1.14 之後的版本、9.0.81 之後的版本或 8.5.94 之後的版本,以修正此問題。
(CVE-2023-42795)

- HTTP/2 通訊協定允許拒絕服務 (伺服器資源消耗),因為要求取消可快速重設許多資料流,如 2023 年 8 月到 2023 年 10 月間遭到的猖獗惡意攻擊。(CVE-2023-44487)

- Apache Tomcat.Tomcat 11.0.0-M1 至 11.0.0-M11、10.1.0-M1 至 10.1.13、9.0.0-M1 至 9.0.81 以及 8.5.0 至 8.5.93 中未正確剖析 HTTP 結尾標頭。因而存在不當輸入驗證弱點。無效的特製結尾標頭可造成 Tomcat 將單一要求視為多個要求,進而導致在反向代理伺服器後面時要求走私。建議使用者升級至 11.0.0-M12 之後的版本、10.1.14 之後的版本、9.0.81 之後的版本或 8.5.94 之後的版本,以修正此問題。(CVE-2023-45648)

請注意,Nessus 並未測試這些問題,而是僅依據應用程式自我報告的版本號碼作出判斷。

解決方案

執行「yum update tomcat8」以更新系統。

另請參閱

https://alas.aws.amazon.com/ALAS-2023-1868.html

https://alas.aws.amazon.com/cve/html/CVE-2023-42795.html

https://alas.aws.amazon.com/cve/html/CVE-2023-44487.html

https://alas.aws.amazon.com/cve/html/CVE-2023-45648.html

https://alas.aws.amazon.com/faqs.html

Plugin 詳細資訊

嚴重性: Medium

ID: 183405

檔案名稱: ala_ALAS-2023-1868.nasl

版本: 1.5

類型: local

代理程式: unix

已發布: 2023/10/19

已更新: 2024/2/23

支援的感應器: Agentless Assessment, Frictionless Assessment Agent, Frictionless Assessment AWS, Nessus Agent, Nessus

風險資訊

VPR

風險因素: Medium

分數: 6.7

CVSS v2

風險因素: Medium

基本分數: 5

時間分數: 4.1

媒介: CVSS2#AV:N/AC:L/Au:N/C:N/I:P/A:N

CVSS 評分資料來源: CVE-2023-45648

CVSS v3

風險因素: Medium

基本分數: 5.3

時間分數: 4.9

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N

時間媒介: CVSS:3.0/E:F/RL:O/RC:C

弱點資訊

CPE: p-cpe:/a:amazon:linux:tomcat8-el-3.0-api, p-cpe:/a:amazon:linux:tomcat8-javadoc, p-cpe:/a:amazon:linux:tomcat8-webapps, p-cpe:/a:amazon:linux:tomcat8-admin-webapps, p-cpe:/a:amazon:linux:tomcat8, p-cpe:/a:amazon:linux:tomcat8-lib, p-cpe:/a:amazon:linux:tomcat8-docs-webapp, p-cpe:/a:amazon:linux:tomcat8-jsp-2.3-api, cpe:/o:amazon:linux, p-cpe:/a:amazon:linux:tomcat8-log4j, p-cpe:/a:amazon:linux:tomcat8-servlet-3.1-api

必要的 KB 項目: Host/local_checks_enabled, Host/AmazonLinux/release, Host/AmazonLinux/rpm-list

可被惡意程式利用: true

可輕鬆利用: Exploits are available

修補程式發佈日期: 2023/10/16

弱點發布日期: 2023/10/10

CISA 已知遭惡意利用弱點到期日: 2023/10/31

參考資訊

CVE: CVE-2023-42795, CVE-2023-44487, CVE-2023-45648

IAVA: 2023-A-0534-S

IAVB: 2023-B-0083-S