PHP 4.x < 4.3.0 ZendEngine 整數溢位

high Nessus Plugin ID 17796

Synopsis

遠端伺服器上可以執行任意程式碼。

描述

遠端主機執行的 PHP 4.x 版比 4.3.0 舊。因此,據稱陣列建立會發生整數溢位,這可由傳遞至「unserialize()」函式的使用者輸入觸發。

成功惡意利用此弱點可導致攻擊者在此主機上執行任意程式碼。

解決方案

請升級至 PHP 4.3.0 或更新版本。

另請參閱

http://www.hardened-php.net/advisory_092006.133.html

Plugin 詳細資訊

嚴重性: High

ID: 17796

檔案名稱: php_4_3_0_zendengine.nasl

版本: 1.7

類型: remote

系列: CGI abuses

已發布: 2012/1/11

已更新: 2022/4/11

組態: 啟用徹底檢查

風險資訊

VPR

風險因素: Medium

分數: 6.7

CVSS v2

風險因素: High

基本分數: 7.5

時間分數: 5.9

媒介: AV:N/AC:L/Au:N/C:P/I:P/A:P

時間媒介: E:POC/RL:OF/RC:C

弱點資訊

CPE: cpe:/a:php:php

必要的 KB 項目: www/PHP

可輕鬆利用: No exploit is required

弱點發布日期: 2006/10/5

參考資訊

CVE: CVE-2006-4812

BID: 20349

CWE: 94