PHP 5.1.x < 5.1.5 多個弱點

critical Nessus Plugin ID 17713

Synopsis

遠端 Web 伺服器使用受到多個弱點影響的 PHP 版本。

描述

根據其標題,遠端主機上安裝的 PHP 5.x 版本比 5.1.5 舊。這些版本可能受到以下弱點影響:

- PHP 版 c-client 程式庫 2000、2001 或 2004 未檢查 safe_mode 或 open_basedir 函式。
(CVE-2006-1017)

- sscanf 函式中存在一個緩衝區溢位問題。
(CVE-2006-4020)

- file_exists 和 imap_reopen 函式未檢查 safe_mode 和 open_basedir 設定,這可允許本機使用者繞過設定。(CVE-2006-4481)

- ext/standard/string.c 的 str_repeat 和 wordwrap 函式中存在多個堆積型緩衝區溢位問題。(CVE-2006-4482)

- 在 open_basedir 或 safe_mode 已啟用的情況下,cURL 延伸模組檔案允許 CURLOPT_FOLLOWLOCATION 選項,這可允許攻擊者執行未經授權的動作。(CVE-2006-4483)

- 在 GD 延伸模組內,ext/gd/libgd/gd_gif_in.c 的 LWZReadByte_ 函式中存在一個緩衝區溢位弱點。(CVE-2006-4484)

- stripos 函式受到一個超出邊界讀取錯誤影響。(CVE-2006-4485)

解決方案

升級為 PHP 5.1.5 或更新版本。

另請參閱

https://bugs.php.net/bug.php?id=38322

http://www.php.net/releases/5_1_5.php

Plugin 詳細資訊

嚴重性: Critical

ID: 17713

檔案名稱: php_5_1_5.nasl

版本: 1.8

類型: remote

系列: CGI abuses

已發布: 2011/11/18

已更新: 2022/4/11

組態: 啟用徹底檢查

風險資訊

VPR

風險因素: Medium

分數: 6.3

CVSS v2

風險因素: Critical

基本分數: 10

時間分數: 7.8

媒介: AV:N/AC:L/Au:N/C:C/I:C/A:C

時間媒介: E:POC/RL:OF/RC:C

弱點資訊

CPE: cpe:/a:php:php

必要的 KB 項目: www/PHP

可輕鬆利用: No exploit is required

修補程式發佈日期: 2006/8/17

弱點發布日期: 2006/2/28

參考資訊

CVE: CVE-2006-1017, CVE-2006-4020, CVE-2006-4481, CVE-2006-4482, CVE-2006-4483, CVE-2006-4484, CVE-2006-4485

BID: 16878, 19415, 19582

CWE: 119