PHP 5.1.x < 5.1.2 多個弱點

high Nessus Plugin ID 17712

Synopsis

遠端 Web 伺服器使用受到多個弱點影響的 PHP 版本。

描述

根據其標題,遠端主機上安裝的 PHP 5.1.x 版本比 5.1.2 舊。這些版本可能受到多個弱點影響:

- mysqli 延伸模組的錯誤報告功能中存在一個格式字串弱點。
(CVE-2006-0200)

- 存在多個 HTTP 回應分割弱點,這些弱點將允許遠端攻擊者透過特製的 Set-Cookie 標頭來插入任意 HTTP 標頭。(CVE-2006-0207)

- 當 display_errors 和 html_errors 啟動時,存在多個跨網站指令碼弱點。(CVE-2006-0208)

解決方案

升級至 PHP 5.1.2 版或更新版本。

另請參閱

http://www.php.net/releases/5_1_2.php

Plugin 詳細資訊

嚴重性: High

ID: 17712

檔案名稱: php_5_1_2.nasl

版本: 1.7

類型: remote

系列: CGI abuses

已發布: 2011/11/18

已更新: 2022/4/11

組態: 啟用徹底檢查

風險資訊

VPR

風險因素: Medium

分數: 5.9

CVSS v2

風險因素: High

基本分數: 9.3

時間分數: 6.9

媒介: AV:N/AC:M/Au:N/C:C/I:C/A:C

時間媒介: E:U/RL:OF/RC:C

弱點資訊

CPE: cpe:/a:php:php

必要的 KB 項目: www/PHP

可輕鬆利用: No exploit is required

修補程式發佈日期: 2006/1/12

弱點發布日期: 2006/1/11

參考資訊

CVE: CVE-2006-0200, CVE-2006-0207, CVE-2006-0208

BID: 16220, 16803

CWE: 134