PHP 5.x < 5.1.0 多個弱點

medium Nessus Plugin ID 17711

Synopsis

遠端 Web 伺服器使用受到多個弱點影響的 PHP 版本。

描述

根據其標題,遠端主機上安裝的 PHP 5.x 版本比 5.1.0 舊。這些版本可能受到多個弱點影響:

- phpinfo() 中存在一個跨網站指令碼弱點。

- ext/curl 和 ext/gd 中存在多個 safe_mode/open_basedir 繞過弱點。

- 可能會覆寫 $GLOBALS,這是因為檔案上傳處理函式 extract() 和 import_request_variables() 中的一個問題所導致。

- 當要求因為 parse_str() 呼叫期間的 memory_limit 限制而終止時,存在一個問題,此問題可導致註冊全域啟動。

- 在允許的 basedir 中的結尾斜線存在一個問題。

- Apache 2 上呼叫 virtual() 時存在一個問題,此問題允許攻擊者繞過特定的組態指示詞,例如 safe_mode 或 open_basedir。

- mb_send_mail() 函式中存在一個可能的標頭插入。

- Apache 模組中的 apache2handler SAPI 允許攻擊者造成拒絕服務。

解決方案

升級至 PHP 5.1.0 版或更新版本。

另請參閱

http://www.php.net/releases/5_1_0.php

Plugin 詳細資訊

嚴重性: Medium

ID: 17711

檔案名稱: php_5_1_0.nasl

版本: 1.7

類型: remote

系列: CGI abuses

已發布: 2011/11/18

已更新: 2022/4/11

組態: 啟用徹底檢查

風險資訊

VPR

風險因素: Low

分數: 3.6

CVSS v2

風險因素: Medium

基本分數: 5

時間分數: 3.7

媒介: AV:N/AC:L/Au:N/C:N/I:N/A:P

時間媒介: E:U/RL:OF/RC:C

弱點資訊

CPE: cpe:/a:php:php

必要的 KB 項目: www/PHP

可輕鬆利用: No exploit is required

修補程式發佈日期: 2006/1/12

弱點發布日期: 2006/1/11

參考資訊

CVE: CVE-2005-3319, CVE-2005-3883

BID: 15177, 15571

CWE: 20, 74, 79, 442, 629, 711, 712, 722, 725, 750, 751, 800, 801, 809, 811, 864, 900, 928, 931, 990