PHP < 4.4.4 多種弱點

high Nessus Plugin ID 17710

Synopsis

遠端 Web 伺服器使用受到多個弱點影響的 PHP 版本。

描述

根據其標題,遠端主機上安裝的 PHP 版本舊於 4.4.4。因此可能會受到以下弱點影響:

- PHP 版 c-client 程式庫 2000、2001 或 2004 未檢查 safe_mode 或 open_basedir 函式。
(CVE-2006-1017)

- sscanf 函式中存在一個緩衝區溢位問題。
(CVE-2006-4020)

解決方案

升級為 PHP 4.4.4 或更新版本。

另請參閱

https://bugs.php.net/bug.php?id=38322

http://www.php.net/releases/4_4_4.php

Plugin 詳細資訊

嚴重性: High

ID: 17710

檔案名稱: php_4_4_4.nasl

版本: 1.9

類型: remote

系列: CGI abuses

已發布: 2011/11/18

已更新: 2022/4/11

組態: 啟用徹底檢查

風險資訊

VPR

風險因素: Medium

分數: 6.3

CVSS v2

風險因素: High

基本分數: 9.3

時間分數: 7.3

媒介: AV:N/AC:M/Au:N/C:C/I:C/A:C

時間媒介: E:POC/RL:OF/RC:C

弱點資訊

CPE: cpe:/a:php:php

必要的 KB 項目: www/PHP

可輕鬆利用: No exploit is required

修補程式發佈日期: 2006/1/12

弱點發布日期: 2006/1/11

參考資訊

CVE: CVE-2006-1017, CVE-2006-4020

BID: 16878, 19415