CentOS 8:mysql:8.0 (CESA-2023: 3087)

medium Nessus Plugin ID 175911

概要

遠端 CentOS 主機缺少一個或多個安全性更新。

說明

遠端 CentOS Linux 8 主機上安裝的套件受到 CESA-2023: 3087 公告中提及的多個弱點影響。

- Oracle MySQL 的 MySQL Server 產品中存在的弱點 (元件:Server: Optimizer)。受到影響的支援版本是 8.0.30 和之前的版本。攻擊此弱點的難度較小,經由多個通訊協定存取網路的高權限攻擊者可藉此入侵 MySQL Server。若成功攻擊此弱點,未經授權即可造成 MySQL 伺服器懸置或經常重複性當機 (完全 DOS)。(CVE-2022-21594、CVE-2022-21640、CVE-2022-39400、CVE-2023-21864、CVE-2023-21865、CVE-2023-21917)

- Oracle MySQL 的 MySQL Server 產品中存在的弱點 (元件:Server: Stored Procedure)。受到影響的支援版本是 8.0.30 和之前的版本。攻擊此弱點的難度較小,經由多個通訊協定存取網路的高權限攻擊者可藉此入侵 MySQL Server。若成功攻擊此弱點,未經授權即可造成 MySQL 伺服器懸置或經常重複性當機 (完全 DOS)。(CVE-2022-21599)

- Oracle MySQL 的 MySQL Server 產品中存在的弱點 (元件:InnoDB)。受到影響的支援版本是 8.0.30 和之前的版本。攻擊此弱點的難度較小,經由多個通訊協定存取網路的高權限攻擊者可藉此入侵 MySQL Server。若攻擊成功,攻擊者可在未經授權的情況下造成 MySQL 伺服器懸置或經常重複性當機 (完全 DOS)。(CVE-2022-21604、CVE-2022-21637)

- Oracle MySQL 的 MySQL Server 產品中存在的弱點 (元件:Server: Optimizer)。受到影響的支援版本是 5.7.39 與更早版本,以及 8.0.30 與更早版本。攻擊此弱點的難度較小,經由多個通訊協定存取網路的高權限攻擊者可藉此入侵 MySQL 伺服器。
若成功攻擊此弱點,未經授權即可造成 MySQL 伺服器懸置或經常重複性當機 (完全 DOS)。(CVE-2022-21608)

- Oracle MySQL 的 MySQL Server 產品中存在的弱點 (元件:InnoDB)。受到影響的支援版本是 8.0.30 和之前的版本。難以惡意利用的弱點允許高權限的攻擊者登入 MySQL 伺服器執行用以危害 MySQL 伺服器的基礎結構。若成功攻擊此弱點,未經授權即可造成 MySQL 伺服器懸置或經常重複性當機 (完全 DOS)。(CVE-2022-21611)

- Oracle MySQL 的 MySQL Server 產品中存在的弱點 (元件:Server: Connection Handling)。
受到影響的支援版本是 5.7.39 與更早版本,以及 8.0.30 與更早版本。攻擊此弱點的難度較小,經由多個通訊協定存取網路的高權限攻擊者可藉此入侵 MySQL 伺服器。若成功攻擊此弱點,未經授權即可造成 MySQL 伺服器懸置或經常重複性當機 (完全 DOS)。(CVE-2022-21617)

- Oracle MySQL 的 MySQL Server 產品中存在的弱點 (元件:Server: Optimizer)。受到影響的支援版本是 8.0.30 和之前的版本。攻擊此弱點有一定難度,可以透過多個通訊協定存取網路的高權限攻擊者可藉此入侵 MySQL 伺服器。若成功攻擊此弱點,未經授權即可造成 MySQL 伺服器懸置或經常重複性當機 (完全 DOS)。(CVE-2022-21625)

- Oracle MySQL 的 MySQL Server 產品中存在的弱點 (元件:Server: Security: Privileges)。
受到影響的支援版本是 8.0.30 和之前的版本。攻擊此弱點的難度較小,經由多個通訊協定存取網路的高權限攻擊者可藉此入侵 MySQL Server。若成功攻擊此弱點,未經授權即可造成 MySQL 伺服器懸置或經常重複性當機 (完全 DOS)。(CVE-2022-21632)

- Oracle MySQL 的 MySQL Server 產品中存在的弱點 (元件:Server: Replication)。受到影響的支援版本是 8.0.30 和之前的版本。攻擊此弱點的難度較小,經由多個通訊協定存取網路的高權限攻擊者可藉此入侵 MySQL Server。若成功攻擊此弱點,未經授權即可造成 MySQL 伺服器懸置或經常重複性當機 (完全 DOS)。(CVE-2022-21633)

- Oracle MySQL 的 MySQL Server 產品中存在的弱點 (元件:Server: Optimizer)。受到影響的支援版本是 8.0.30 和之前的版本。攻擊此弱點的難度較小,經由多個通訊協定存取網路的低權限攻擊者可藉此入侵 MySQL 伺服器。若攻擊成功,攻擊者可在未經授權的情況下造成 MySQL 伺服器懸置或經常重複性當機 (完全 DOS)。(CVE-2022-39408、CVE-2022-39410)

- Oracle MySQL 的 MySQL Server 產品中存在的弱點 (元件:伺服器:DML)。受到影響的支援版本是 8.0.31 和之前的版本。攻擊此弱點的難度較小,經由多個通訊協定存取網路的高權限攻擊者可藉此入侵 MySQL Server。若成功攻擊此弱點,未經授權即可造成 MySQL 伺服器懸置或經常重複性當機 (完全 DOS)。(CVE-2023-21836)

- Oracle MySQL 的 MySQL Server 產品中存在的弱點 (元件:Server: Optimizer)。受到影響的支援版本是 8.0.31 和之前的版本。攻擊此弱點的難度較小,經由多個通訊協定存取網路的高權限攻擊者可藉此入侵 MySQL 伺服器。若攻擊成功,攻擊者未經授權即可造成 MySQL Server 懸置或經常重複性當機 (完全 DOS)。(CVE-2023-21863、CVE-2023-21867、CVE-2023-21870、CVE-2023-21873、CVE-2023-21876、CVE-2023-21878、CVE-2023-21879、CVE-2023-21881、CVE-2023-21883、CVE-2023-21913)

- Oracle MySQL 的 MySQL Server 產品中存在的弱點 (元件:Server: Optimizer)。受到影響的支援版本是 8.0.31 和之前的版本。攻擊此弱點的難度較小,經由多個通訊協定存取網路的低權限攻擊者可藉此入侵 MySQL 伺服器。若成功攻擊此弱點,未經授權即可造成 MySQL 伺服器懸置或經常重複性當機 (完全 DOS)。(CVE-2023-21868)

- Oracle MySQL 的 MySQL Server 產品中存在的弱點 (元件:InnoDB)。受到影響的支援版本是 8.0.31 和之前的版本。攻擊此弱點的難度較小,經由多個通訊協定存取網路的高權限攻擊者可藉此入侵 MySQL 伺服器。若成功攻擊此弱點,未經授權即可造成 MySQL 伺服器懸置或經常重複性當機 (完全 DOS),以及未經授權即可更新、插入或刪除某些 MySQL 伺服器可存取資料。
(CVE-2023-21869, CVE-2023-21877, CVE-2023-21880)

- Oracle MySQL 的 MySQL Server 產品中存在的弱點 (元件:InnoDB)。受到影響的支援版本是 8.0.31 和之前的版本。攻擊此弱點的難度較小,經由多個通訊協定存取網路的高權限攻擊者可藉此入侵 MySQL Server。若成功攻擊此弱點,未經授權即可造成 MySQL 伺服器懸置或經常重複性當機 (完全 DOS)。(CVE-2023-21871)

- Oracle MySQL 的 MySQL Server 產品中存在的弱點 (元件:Server: 執行緒集區)。受到影響的支援版本是 8.0.30 和之前的版本。攻擊此弱點的難度較小,經由多個通訊協定存取網路的高權限攻擊者可藉此入侵 MySQL Server。若攻擊成功,攻擊者未經授權即可造成 MySQL 伺服器局部拒絕服務 (局部 DOS)。(CVE-2023-21874)

- Oracle MySQL 的 MySQL Server 產品中存在的弱點 (元件:Server: Security: Encryption)。
受到影響的支援版本是 8.0.31 和之前的版本。攻擊此弱點有一定難度,可以透過多個通訊協定存取網路的高權限攻擊者可藉此入侵 MySQL 伺服器。若成功攻擊此弱點,攻擊者未經授權即可建立、刪除或修改重要資料或所有的 MySQL Server 可存取資料,並且可在未經授權的情況下造成 MySQL Server 懸置或經常重複性當機 (完全 DOS)。(CVE-2023-21875)

- Oracle MySQL 的 MySQL Server 產品中存在的弱點 (元件:Server: Optimizer)。受到影響的支援版本是 8.0.31 和之前的版本。攻擊此弱點的難度較小,經由多個通訊協定存取網路的高權限攻擊者可藉此入侵 MySQL 伺服器。若攻擊成功,攻擊者未經授權即可更新、插入或刪除部分 MySQL 伺服器可存取資料。(CVE-2023-21882)

- Oracle MySQL 的 MySQL Server 產品中存在的弱點 (元件:Server: GIS)。受到影響的支援版本是 8.0.31 和之前的版本。攻擊此弱點的難度較小,經由多個通訊協定存取網路的高權限攻擊者可藉此入侵 MySQL Server。若成功攻擊此弱點,未經授權即可造成 MySQL 伺服器懸置或經常重複性當機 (完全 DOS)。(CVE-2023-21887)

- Oracle MySQL 的 MySQL Server 產品中存在的弱點 (元件:Server: Security: Privileges)。
受到影響的支援版本是 5.7.41 與更早版本,以及 8.0.30 與更早版本。攻擊此弱點的難度較小,經由多個通訊協定存取網路的未經驗證攻擊者可藉此入侵 MySQL Server。若成功攻擊此弱點,未經授權即可造成 MySQL 伺服器懸置或經常重複性當機 (完全 DOS)。(CVE-2023-21912)

- Oracle MySQL 的 MySQL Server 產品中存在的弱點 (元件:Server: Connection Handling)。
受到影響的支援版本是 5.7.40 與更早版本,以及 8.0.31 與更早版本。攻擊此弱點的難度較小,經由多個通訊協定存取網路的高權限攻擊者可藉此入侵 MySQL 伺服器。若攻擊成功,攻擊者未經授權即可造成 MySQL 伺服器局部拒絕服務 (局部 DOS)。(CVE-2023-21963)

- Oracle MySQL 的 MySQL Server 產品中存在的弱點 (元件:Server: Optimizer)。受到影響的支援版本是 5.7.42 與更早版本,以及 8.0.31 與更早版本。攻擊此弱點的難度較小,經由多個通訊協定存取網路的高權限攻擊者可藉此入侵 MySQL 伺服器。
若攻擊成功,攻擊者可在未經授權的情況下造成 MySQL 伺服器懸置或經常重複性當機 (完全 DOS)。(CVE-2023-22015、CVE-2023-22026)

- Oracle MySQL 的 MySQL Server 產品中存在的弱點 (元件:Server: Optimizer)。受到影響的支援版本是 5.7.43 與更早版本,以及 8.0.31 與更早版本。攻擊此弱點的難度較小,經由多個通訊協定存取網路的高權限攻擊者可藉此入侵 MySQL 伺服器。
若成功攻擊此弱點,未經授權即可造成 MySQL 伺服器懸置或經常重複性當機 (完全 DOS)。(CVE-2023-22028)

請注意,Nessus 並未測試這些問題,而是僅依據應用程式自我報告的版本號碼作出判斷。

解決方案

更新受影響的 mecab-ipadic 和/或 mecab-ipadic-EUCJP 套件。

另請參閱

https://access.redhat.com/errata/RHSA-2023:3087

Plugin 詳細資訊

嚴重性: Medium

ID: 175911

檔案名稱: centos8_RHSA-2023-3087.nasl

版本: 1.1

類型: local

代理程式: unix

已發布: 2023/5/17

已更新: 2024/2/8

支援的感應器: Frictionless Assessment AWS, Frictionless Assessment Azure, Frictionless Assessment Agent, Agentless Assessment, Nessus

風險資訊

VPR

風險因素: Medium

分數: 5.2

CVSS v2

風險因素: Medium

基本分數: 6.8

時間分數: 5

媒介: CVSS2#AV:N/AC:L/Au:M/C:N/I:P/A:C

CVSS 評分資料來源: CVE-2023-21880

CVSS v3

風險因素: Medium

基本分數: 5.9

時間分數: 5.2

媒介: CVSS:3.0/AV:N/AC:H/PR:H/UI:N/S:U/C:N/I:H/A:H

時間媒介: CVSS:3.0/E:U/RL:O/RC:C

CVSS 評分資料來源: CVE-2023-21875

弱點資訊

CPE: cpe:/o:centos:centos:8, p-cpe:/a:centos:centos:mecab-ipadic, p-cpe:/a:centos:centos:mecab-ipadic-eucjp

必要的 KB 項目: Host/local_checks_enabled, Host/cpu, Host/CentOS/release, Host/CentOS/rpm-list

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2023/5/16

弱點發布日期: 2022/10/18

參考資訊

CVE: CVE-2022-21594, CVE-2022-21599, CVE-2022-21604, CVE-2022-21608, CVE-2022-21611, CVE-2022-21617, CVE-2022-21625, CVE-2022-21632, CVE-2022-21633, CVE-2022-21637, CVE-2022-21640, CVE-2022-39400, CVE-2022-39408, CVE-2022-39410, CVE-2023-21836, CVE-2023-21863, CVE-2023-21864, CVE-2023-21865, CVE-2023-21867, CVE-2023-21868, CVE-2023-21869, CVE-2023-21870, CVE-2023-21871, CVE-2023-21873, CVE-2023-21874, CVE-2023-21875, CVE-2023-21876, CVE-2023-21877, CVE-2023-21878, CVE-2023-21879, CVE-2023-21880, CVE-2023-21881, CVE-2023-21882, CVE-2023-21883, CVE-2023-21887, CVE-2023-21912, CVE-2023-21913, CVE-2023-21917, CVE-2023-21963, CVE-2023-22015, CVE-2023-22026, CVE-2023-22028

RHSA: 2023:3087