RHEL 8:核心 (RHSA-2023: 2951)

high Nessus Plugin ID 175900

概要

遠端 Red Hat 主機缺少一個或多個安全性更新。

說明

遠端 Redhat Enterprise Linux 8 主機上安裝的套件受到 RHSA-2023: 2951 公告中提及的多個弱點影響。

- 部分 AMD CPU 可能會暫時執行包括無條件直接分支在內的其他分支,進而可能導致資料洩漏。(CVE-2021-26341)

- 透過 ioctl cmd FBIOPUT_VSCREENINFO 傳送惡意資料至核心時,核心會超出邊界寫入記憶體。(CVE-2021-33655)

- 當透過 ioctl cmd PIO_FONT 設定包含惡意資料的字型時,核心會超出邊界寫入記憶體。
(CVE-2021-33656)

- 在 Linux 核心的 TeleTYpe 子系統中發現超出邊界讀取缺陷。由於 flush_to_ldisc 函式中存在記憶體洩漏弱點,使用者利用 ioctls 的 TIOCSPTLCK、TIOCGPTPEER、TIOCSTI 和 TCXONC 觸發爭用情形時會發生此問題。本機使用者可利用此缺陷造成系統當機,或從記憶體讀取未經授權的隨機資料。(CVE-2022-1462)

- 在使用者強制 ath9k_htc_wait_for_target 函式失敗並顯示部分輸入訊息的方式中,在 Linux 核心的 Atheros 無線介面卡驅動程式中發現一個釋放後使用缺陷。本機使用者可利用此缺陷造成系統當機,或可能提升自己的系統權限。(CVE-2022-1679)

- 啟用陰影索引標籤時,INVPCID 指令會導致呼叫 kvm_mmu_invpcid_gva。如果在 CR0.PG=0 的情況下執行 INVPCID,則不會設定 invlpg 回呼,且結果為 NULL 指標解除參照。
(CVE-2022-1789)

- 在 igmp.c 的 ip_check_mc_rcu 中,可能因不當鎖定造成釋放後使用。這可能會導致本機權限提升,開啓和關閉 inet socket 時不需額外的執行權限。不需使用者互動即可惡意利用。產品:Android 版本:Android 核心 Android ID:A-112551163References: 上游核心 (CVE-2022-20141)

- Linux 核心的 KVM: nVMX 中存在回歸問題,可引致推測執行攻擊。
因為 KVM (L0) 向 L1 通告 eIBRS 支援,L1 認為在執行 L2 後其不需要 retpolines 或 IBPB,所以 L2 可以對 L1 發動 Spectre v2 攻擊。在 L2 具有程式碼執行權限的攻擊者可在主機的間接分支上執行程式碼。建議升級爲 Kernel 6.2 或之前的 commit 2e7eab81425a (CVE-2022-2196)

- 在 Linux 核心 5.16.10 以及之前的所有版本中,某些二進位檔如果是在 2003 年左右建構 (例如,使用 GCC 3.2.2 和 Linux 核心 2.4.20),則可能具有 exec-all 屬性。這可導致系統執行檔案中本應爲不可執行區域中的位元組。(CVE-2022-25265)

- 在 Linux 核心的 nf_conntrack_irc 中發現一個問題,其中的訊息處理可能會發生混淆並且與訊息錯誤對應。當使用者在已設定 nf_conntrack_irc 的情況下使用未加密的 IRC 時,可能能夠繞過防火牆。(CVE-2022-2663)

- 當同時發生多個對 xfrm_probe_algs 的呼叫時,發現 Linux 核心中用於轉換封包的 IP 架構 (XFRM 子系統) 存在爭用情形。此缺陷讓本機攻擊者可能透過執行超出邊界讀取並將其複製到通訊端,來觸發超出邊界寫入或洩漏核心堆積記憶體。(CVE-2022-3028)

- Linux 核心 5.17.2 之前版本無法正確處理 seccomp 權限。PTRACE_SEIZE 程式碼路徑允許攻擊者繞過針對設定 PT_SUSPEND_SECCOMP 旗標的預定限制。(CVE-2022-30594)

- 在 Linux 核心的 video4linux 驅動程式中,發現使用者針對以 Empia 28xx 爲基礎的電視卡觸發 em28xx_usb_probe() 的方式中存在釋放後使用缺陷。本機使用者可利用此缺陷使系統當機,或可能提升其在系統中的權限。(CVE-2022-3239)

- 在 Linux 核心中發現一個弱點。目前已將其歸類為「有問題」。受到此弱點影響的是 IPv6 Handler 元件的 ipv6_renew_options 函式。攻擊者可利用此弱點造成記憶體洩漏。攻擊者可在遠端執行此攻擊。建議套用修補程式以修正此問題。
已爲此弱點指派識別碼 VDB-211021。(CVE-2022-3524)

- 在 Linux 核心中發現一個歸類爲「嚴重」的弱點。此弱點會影響 Bluetooth 元件中 net/bluetooth/l2cap_core.c 檔案的 l2cap_reassemble_sdu 函式。操控此弱點可導致釋放後使用。建議套用修補程式以修正此問題。此弱點的相關識別碼是 VDB-211087。(CVE-2022-3564)

- 在 Linux 核心中發現一個歸類爲「有問題」的弱點。此弱點會影響 TCP 處理常式元件的 tcp_getsockopt/tcp_setsockopt 函式。利用此弱點可導致爭用情形。建議套用修補程式以修正此問題。已爲此弱點指派識別碼 VDB-211089。(CVE-2022-3566)

- 在 Linux 核心中發現一個歸類爲「有問題」的弱點。此弱點會影響 IPv6 處理常式元件的 inet6_stream_ops/inet6_dgram_ops 函式。利用此弱點可導致爭用情形。建議套用修補程式以修正此問題。已爲此弱點指派識別碼 VDB-211090。(CVE-2022-3567)

- 在 Linux 核心中發現一個歸類爲「有問題」的弱點。此弱點會影響 Bluetooth 元件中 net/bluetooth/l2cap_core.c 檔案的 l2cap_recv_acldata 函式。攻擊者可利用此弱點造成記憶體洩漏。建議套用修補程式以修正此問題。已爲此弱點指派識別碼 VDB-211918。(CVE-2022-3619)

- 在 Linux 核心中發現一個弱點。目前已將其歸類為「有問題」。此弱點會影響 BPF 元件中 mm/gup.c 檔案的 follow_page_pte 函式。利用此弱點可導致爭用情形。攻擊者可在遠端執行此攻擊。建議套用修補程式以修正此問題。已爲此弱點指派識別碼 VDB-211921。(CVE-2022-3623)

- 在 Linux 核心中發現一個弱點。目前已將其歸類為「嚴重」。這會影響 IPsec 元件中 net/core/devlink.c 檔案的 devlink_param_set/devlink_param_get 函式。操控此弱點可導致釋放後使用。建議套用修補程式以修正此問題。已爲此弱點指派識別碼 VDB-211929。(CVE-2022-3625)

- 在 Linux 核心 Broadcom Full MAC Wi-Fi 驅動程式中發現緩衝區溢位缺陷。當使用者連線至惡意 USB 裝置時,會發生此問題。本機使用者可利用此缺陷造成系統當機,或提升自己的系統權限。(CVE-2022-3628)

- 在 Linux 核心中發現重複釋放記憶體缺陷。Intel GVT-g 圖形驅動程式觸發 VGA 卡系統資源過載,造成 intel_gvt_dma_map_guest_page 函式失敗。本機使用者可利用此問題導致系統當機。(CVE-2022-3707)

- 在 5.19 版之前的 Linux 核心中,發現 include/asm-generic/tlb.h 中存在問題。由於存在爭用情形 (unmap_mapping_range 與 munmap),裝置驅動程式可在頁面仍具有過時 TLB 項目時釋放此頁面。只有在使用 VM_PFNMAP VMA 的情況下,才會發生此問題。(CVE-2022-39188)

- 在 5.18.17 版之前的 Linux 核心中,發現 x86 KVM 子系統存在問題。無權限的來賓使用者可入侵來賓核心,這是因為在某些 KVM_VCPU_PREEMPTED 情況下,程式未正確處理 TLB 排清作業。(CVE-2022-39189)

- 在 Linux 核心 5.19.10 及其之前的所有版本中,drivers/media/dvb-core/dmxdev.c 中存在由 refcount 爭用造成的釋放後使用問題,此問題影響 dvb_demux_open 和 dvb_dmxdev_release。(CVE-2022-41218)

- 在 Linux 核心的第 2 層通道通訊協定 (L2TP) 中發現一個缺陷。清除 sk_user_data 時遺漏鎖定可導致爭用條件和 NULL 指標解除參照弱點。本機使用者可利用此缺陷造成系統當機,進而引發拒絕服務。(CVE-2022-4129)

- 在 5.19.16 版之前的 Linux 核心中發現一個問題。能夠插入 WLAN 框架的攻擊者可在 net/mac80211/scan.c 的 ieee80211_bss_info_update 函式中造成緩衝區溢位。(CVE-2022-41674)

- 在 5.19.7 版之前的 Linux 核心中,mm/rmap.c 存在與分葉 anon_vma 雙重重複使用相關的釋放後使用問題。
(CVE-2022-42703)

- 在 Linux 核心 5.1 至 5.19.16 之前的 5.19.x 版中,處理多 BSS 元素時,mac80211 堆疊會產生多個參照計數錯誤,本機攻擊者 (能夠插入 WLAN 框架) 可利用這些錯誤觸發釋放後使用條件,進而可能執行程式碼。(CVE-2022-42720)

- 在 Linux 核心 5.1 至 5.19.16 之前的 5.19.x 版中,處理 BSS 時,mac80211 堆疊會產生清單管理錯誤,本機攻擊者 (能夠插入 WLAN 框架) 可利用此錯誤損毀關聯的清單,進而可能執行程式碼。(CVE-2022-42721)

- 在 Linux 核心 5.8 至 5.19.16 之前的 5.19.x 版中,能夠將 WLAN 框架插入 mac80211 堆疊的本機攻擊者可針對 P2P 裝置的信標保護執行 NULL 指標解除參照和拒絕服務攻擊。(CVE-2022-42722)

- 在 Linux 核心 5.19.15 之前版本以及低於 6.0.1 的 6.x 版中,usbmon 的 drivers/usb/mon/mon_bin.c 允許使用者空間用戶端損毀監視器的內部記憶體。(CVE-2022-43750)

- 在 6.1.6 版之前的 Linux 核心中,流量控制子系統中存在 NULL 指標解除參照錯誤,允許無權限的使用者透過以 tc qdisc 和 tc class 命令設定的特製流量控制組態,觸發拒絕服務 (系統當機) 。這會影響 net/sched/sch_api.c 中的 qdisc_graft。(CVE-2022-47929)

- 在 Linux 核心的 Network 子元件中,在 net/ipv6/raw.c 的 rawv6_push_pending_frames 中發現一個 NULL 指標解除參照缺陷。此缺陷會導致系統當機。(CVE-2023-0394)

- Linux 核心中有一個釋放後使用弱點,可遭惡意利用來提升本機權限。必須設定核心組態旗標 CONFIG_TLS 或 CONFIG_XFRM_ESPINTCP,才能達到弱點,但該作業不需要任何權限。struct inet_connection_sock 的 icsk_ulp_data 有一個釋放後使用錯誤。啟用 CONFIG_TLS 時,使用者可在已連線的 tcp 通訊端上安裝 tls 內容 (struct tls_context)。如果此通訊端中斷連線並重新用作接聽程式,則不會清除內容。如果從接聽程式建立新的通訊端,則內容會繼承並受到影響。setsockopt TCP_ULP 作業不需要任何權限。建議升級過去的提交 2c02d41d71f90a5168391b6a5f2954112ba2307c (CVE-2023-0461)

- 在 Linux 核心的 fs/cifs/connect.c 內的 reconn_set_ipaddr_from_hostname 中發現一個釋放後使用缺陷。當忘記將可用指標 server->hostname 設定為 NULL 時,會發生此問題,進而導致無效的指標要求。(CVE-2023-1195)

- 在 Linux 核心中發現記憶體管理子元件 fs/proc/task_mmu.c 存在爭用問題。
具有使用者特權的本機攻擊者可藉由此問題造成拒絕服務。(CVE-2023-1582)

- 在 Linux 6.1.4 及其之前的所有版本中,由於類型混淆 (非負數有時可指示 TC_ACT_SHOT 條件,而非有效的分類結果),net/sched/sch_cbq.c 中的 cbq_classify 允許攻擊者造成系統拒絕服務。(CVE-2023-23454)

請注意,Nessus 並未測試這些問題,而是僅依據應用程式自我報告的版本號碼作出判斷。

解決方案

更新受影響的套件。

另請參閱

https://access.redhat.com/security/cve/CVE-2021-26341

https://access.redhat.com/security/cve/CVE-2021-33655

https://access.redhat.com/security/cve/CVE-2021-33656

https://access.redhat.com/security/cve/CVE-2022-1462

https://access.redhat.com/security/cve/CVE-2022-1679

https://access.redhat.com/security/cve/CVE-2022-1789

https://access.redhat.com/security/cve/CVE-2022-2196

https://access.redhat.com/security/cve/CVE-2022-2663

https://access.redhat.com/security/cve/CVE-2022-3028

https://access.redhat.com/security/cve/CVE-2022-3239

https://access.redhat.com/security/cve/CVE-2022-3524

https://access.redhat.com/security/cve/CVE-2022-3564

https://access.redhat.com/security/cve/CVE-2022-3566

https://access.redhat.com/security/cve/CVE-2022-3567

https://access.redhat.com/security/cve/CVE-2022-3619

https://access.redhat.com/security/cve/CVE-2022-3623

https://access.redhat.com/security/cve/CVE-2022-3625

https://access.redhat.com/security/cve/CVE-2022-3628

https://access.redhat.com/security/cve/CVE-2022-3707

https://access.redhat.com/security/cve/CVE-2022-4129

https://access.redhat.com/security/cve/CVE-2022-20141

https://access.redhat.com/security/cve/CVE-2022-25265

https://access.redhat.com/security/cve/CVE-2022-30594

https://access.redhat.com/security/cve/CVE-2022-39188

https://access.redhat.com/security/cve/CVE-2022-39189

https://access.redhat.com/security/cve/CVE-2022-41218

https://access.redhat.com/security/cve/CVE-2022-41674

https://access.redhat.com/security/cve/CVE-2022-42703

https://access.redhat.com/security/cve/CVE-2022-42720

https://access.redhat.com/security/cve/CVE-2022-42721

https://access.redhat.com/security/cve/CVE-2022-42722

https://access.redhat.com/security/cve/CVE-2022-43750

https://access.redhat.com/security/cve/CVE-2022-47929

https://access.redhat.com/security/cve/CVE-2023-0394

https://access.redhat.com/security/cve/CVE-2023-0461

https://access.redhat.com/security/cve/CVE-2023-1195

https://access.redhat.com/security/cve/CVE-2023-1582

https://access.redhat.com/security/cve/CVE-2023-23454

https://access.redhat.com/errata/RHSA-2023:2951

Plugin 詳細資訊

嚴重性: High

ID: 175900

檔案名稱: redhat-RHSA-2023-2951.nasl

版本: 1.2

類型: local

代理程式: unix

已發布: 2023/5/17

已更新: 2024/1/16

支援的感應器: Frictionless Assessment AWS, Frictionless Assessment Azure, Frictionless Assessment Agent, Nessus Agent, Agentless Assessment, Nessus

風險資訊

VPR

風險因素: High

分數: 7.3

CVSS v2

風險因素: High

基本分數: 7.2

時間分數: 5.6

媒介: CVSS2#AV:L/AC:L/Au:N/C:C/I:C/A:C

CVSS 評分資料來源: CVE-2022-1679

CVSS v3

風險因素: High

基本分數: 8.8

時間分數: 7.9

媒介: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H

時間媒介: CVSS:3.0/E:P/RL:O/RC:C

CVSS 評分資料來源: CVE-2022-2196

弱點資訊

CPE: cpe:/o:redhat:enterprise_linux:8, p-cpe:/a:redhat:enterprise_linux:bpftool, p-cpe:/a:redhat:enterprise_linux:kernel, p-cpe:/a:redhat:enterprise_linux:kernel-abi-stablelists, p-cpe:/a:redhat:enterprise_linux:kernel-core, p-cpe:/a:redhat:enterprise_linux:kernel-cross-headers, p-cpe:/a:redhat:enterprise_linux:kernel-debug, p-cpe:/a:redhat:enterprise_linux:kernel-debug-core, p-cpe:/a:redhat:enterprise_linux:kernel-debug-devel, p-cpe:/a:redhat:enterprise_linux:kernel-debug-modules, p-cpe:/a:redhat:enterprise_linux:kernel-debug-modules-extra, p-cpe:/a:redhat:enterprise_linux:kernel-devel, p-cpe:/a:redhat:enterprise_linux:kernel-modules, p-cpe:/a:redhat:enterprise_linux:kernel-modules-extra, p-cpe:/a:redhat:enterprise_linux:kernel-tools, p-cpe:/a:redhat:enterprise_linux:kernel-tools-libs, p-cpe:/a:redhat:enterprise_linux:kernel-tools-libs-devel, p-cpe:/a:redhat:enterprise_linux:kernel-zfcpdump, p-cpe:/a:redhat:enterprise_linux:kernel-zfcpdump-core, p-cpe:/a:redhat:enterprise_linux:kernel-zfcpdump-devel, p-cpe:/a:redhat:enterprise_linux:kernel-zfcpdump-modules, p-cpe:/a:redhat:enterprise_linux:kernel-zfcpdump-modules-extra, p-cpe:/a:redhat:enterprise_linux:perf, p-cpe:/a:redhat:enterprise_linux:python3-perf

必要的 KB 項目: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list, Host/cpu

可被惡意程式利用: true

可輕鬆利用: Exploits are available

修補程式發佈日期: 2023/5/16

弱點發布日期: 2021/9/30

參考資訊

CVE: CVE-2021-26341, CVE-2021-33655, CVE-2021-33656, CVE-2022-1462, CVE-2022-1679, CVE-2022-1789, CVE-2022-20141, CVE-2022-2196, CVE-2022-25265, CVE-2022-2663, CVE-2022-3028, CVE-2022-30594, CVE-2022-3239, CVE-2022-3524, CVE-2022-3564, CVE-2022-3566, CVE-2022-3567, CVE-2022-3619, CVE-2022-3623, CVE-2022-3625, CVE-2022-3628, CVE-2022-3707, CVE-2022-39188, CVE-2022-39189, CVE-2022-41218, CVE-2022-4129, CVE-2022-41674, CVE-2022-42703, CVE-2022-42720, CVE-2022-42721, CVE-2022-42722, CVE-2022-43750, CVE-2022-47929, CVE-2023-0394, CVE-2023-0461, CVE-2023-1195, CVE-2023-1582, CVE-2023-23454

CWE: 1188, 119, 120, 123, 125, 20, 276, 281, 362, 366, 401, 415, 416, 421, 440, 476, 552, 667, 668, 705, 787, 923

RHSA: 2023:2951