Debian DSA-5348-1:haproxy - 安全性更新

critical Nessus Plugin ID 171500

概要

遠端 Debian 主機上缺少一個或多個安全性更新。

說明

遠端 Debian 11 主機上安裝的多個套件受到 dsa-5348 公告中提及的多個弱點影響。

- 2.7.3 版之前的 HAProxy 可能允許繞過存取控制,因為在某些情況下會意外遺失 HTTP/1 標頭,即要求走私。HAProxy 中的 HTTP 標頭剖析器可能接受空白標頭欄位名稱,其可用於截斷 HTTP 標頭清單,因而使部分標頭在針對 HTTP/1.0 和 HTTP/1.1 剖析和處理後消失。而對於 HTTP/2 和 HTTP/3 的影響有限,因為標頭在剖析和處理之前就消失了,彷彿標頭不是由用戶端傳送的一樣。已修正版本是 2.7.3、2.6.9、2.5.12、2.4.22、2.2.29 和 2.0.31。(CVE-2023-25725)

- 在 HAProxy 中發現不受控制的資源消耗弱點,此弱點可造成服務損毀。經驗證的遠端攻擊者可利用此弱點在 OpenShift 叢集中執行特製的惡意伺服器。此弱點主要影響可用性。(CVE-2023-0056)

請注意,Nessus 並未測試這些問題,而是僅依據應用程式自我報告的版本號碼作出判斷。

解決方案

升級 haproxy 套件。

針對穩定的發行版本 (bullseye),已在 2.2.9-2+deb11u4 版本中修正這些問題。

另請參閱

https://security-tracker.debian.org/tracker/source-package/haproxy

https://www.debian.org/security/2023/dsa-5348

https://security-tracker.debian.org/tracker/CVE-2023-0056

https://security-tracker.debian.org/tracker/CVE-2023-25725

https://packages.debian.org/source/bullseye/haproxy

Plugin 詳細資訊

嚴重性: Critical

ID: 171500

檔案名稱: debian_DSA-5348.nasl

版本: 1.3

類型: local

代理程式: unix

已發布: 2023/2/15

已更新: 2023/9/4

支援的感應器: Agentless Assessment, Frictionless Assessment Agent, Nessus Agent, Nessus

風險資訊

VPR

風險因素: Medium

分數: 5.2

CVSS v2

風險因素: High

基本分數: 9.4

時間分數: 7.4

媒介: CVSS2#AV:N/AC:L/Au:N/C:N/I:C/A:C

CVSS 評分資料來源: CVE-2023-25725

CVSS v3

風險因素: Critical

基本分數: 9.1

時間分數: 8.2

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:H

時間媒介: CVSS:3.0/E:P/RL:O/RC:C

弱點資訊

CPE: p-cpe:/a:debian:debian_linux:haproxy, p-cpe:/a:debian:debian_linux:haproxy-doc, p-cpe:/a:debian:debian_linux:vim-haproxy, cpe:/o:debian:debian_linux:11.0

必要的 KB 項目: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

可被惡意程式利用: true

可輕鬆利用: Exploits are available

修補程式發佈日期: 2023/2/14

弱點發布日期: 2023/2/14

參考資訊

CVE: CVE-2023-0056, CVE-2023-25725