GitLab 0.0 < 15.4.6 / 15.5 < 15.5.5 / 15.6 < 15.6.1 (CVE-2022-4205)

high Nessus Plugin ID 170060

概要

遠端主機上安裝的 GitLab 版本受到一個弱點影響。

說明

遠端主機上安裝的 GitLab 版本受到下列弱點影響:

- 在 15.6.1、15.5.5 和 15.4.6 版之前的 Gitlab EE/CE 中,使用具有十六進位名稱的分支可覆寫現有的雜湊。(CVE-2022-4205)

請注意,Nessus 並未測試此問題,而是僅依據應用程式自我報告的版本號碼作出判斷。

解決方案

升級至 GitLab 15.4.6、15.5.5、15.6.1 或更新版本。

另請參閱

http://www.nessus.org/u?d98b4337

https://gitlab.com/gitlab-org/gitlab/-/issues/374082

Plugin 詳細資訊

嚴重性: High

ID: 170060

檔案名稱: gitlab_CVE-2022-4205.nasl

版本: 1.7

類型: combined

代理程式: unix

系列: CGI abuses

已發布: 2023/1/16

已更新: 2024/5/17

組態: 啟用徹底檢查

支援的感應器: Nessus Agent, Nessus

風險資訊

VPR

風險因素: Medium

分數: 4.4

CVSS v2

風險因素: High

基本分數: 7.8

時間分數: 6.1

媒介: CVSS2#AV:N/AC:L/Au:N/C:N/I:C/A:N

CVSS 評分資料來源: CVE-2022-4205

CVSS v3

風險因素: High

基本分數: 7.5

時間分數: 6.7

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N

時間媒介: CVSS:3.0/E:P/RL:O/RC:C

弱點資訊

CPE: cpe:/a:gitlab:gitlab

必要的 KB 項目: installed_sw/GitLab

可被惡意程式利用: true

可輕鬆利用: Exploits are available

修補程式發佈日期: 2022/12/12

弱點發布日期: 2022/12/12

參考資訊

CVE: CVE-2022-4205

IAVA: 2022-A-0506-S