Amazon Linux 2:ncurses (ALAS-2022-1893)

high Nessus Plugin ID 168462

Synopsis

遠端 Amazon Linux 2 主機缺少安全性更新。

描述

遠端主機上安裝的 ncurses 版本低於 6.0-8.20170212。因此,會受到 ALAS2-2022-1893 公告中所提及的多個弱點影響。

- 在 ncurses v6.2-1 及之前的所有版本中發現問題,captoinfo.c 中的 _nc_captoinfo 存在堆積型緩衝區溢位弱點。(CVE-2021-39537)

- 在修補程式 20220416 之前的 ncurses 6.3 版中,terminfo 程式庫的 tinfo/read_entry.c 中的 convert_strings 存在超出邊界讀取和區段違規問題。(CVE-2022-29458)

請注意,Nessus 並未測試這些問題,而是僅依據應用程式自我報告的版本號碼作出判斷。

解決方案

執行「yum update ncurses」以更新系統。

另請參閱

https://alas.aws.amazon.com/cve/html/CVE-2021-39537.html

https://alas.aws.amazon.com/cve/html/CVE-2022-29458.html

https://alas.aws.amazon.com/AL2/ALAS-2022-1893.html

Plugin 詳細資訊

嚴重性: High

ID: 168462

檔案名稱: al2_ALAS-2022-1893.nasl

版本: 1.2

類型: local

代理程式: unix

已發布: 2022/12/7

已更新: 2022/12/7

支持的傳感器: Frictionless Assessment AWS, Frictionless Assessment Agent, Nessus Agent, Agentless Assessment

風險資訊

VPR

風險因素: Medium

分數: 6.7

CVSS v2

風險因素: Medium

基本分數: 6.8

時間分數: 5

媒介: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

時間媒介: CVSS2#E:U/RL:OF/RC:C

CVSS 評分資料來源: CVE-2021-39537

CVSS v3

風險因素: High

基本分數: 8.8

時間分數: 7.7

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

時間媒介: CVSS:3.0/E:U/RL:O/RC:C

弱點資訊

CPE: cpe:2.3:o:amazon:linux:2:*:*:*:*:*:*:*, p-cpe:2.3:a:amazon:linux:ncurses:*:*:*:*:*:*:*, p-cpe:2.3:a:amazon:linux:ncurses-base:*:*:*:*:*:*:*, p-cpe:2.3:a:amazon:linux:ncurses-compat-libs:*:*:*:*:*:*:*, p-cpe:2.3:a:amazon:linux:ncurses-debuginfo:*:*:*:*:*:*:*, p-cpe:2.3:a:amazon:linux:ncurses-devel:*:*:*:*:*:*:*, p-cpe:2.3:a:amazon:linux:ncurses-libs:*:*:*:*:*:*:*, p-cpe:2.3:a:amazon:linux:ncurses-static:*:*:*:*:*:*:*, p-cpe:2.3:a:amazon:linux:ncurses-term:*:*:*:*:*:*:*, p-cpe:2.3:a:amazon:linux:ncurses-c\+\+-libs:*:*:*:*:*:*:*

必要的 KB 項目: Host/local_checks_enabled, Host/AmazonLinux/release, Host/AmazonLinux/rpm-list

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2022/12/1

弱點發布日期: 2021/9/20

參考資訊

CVE: CVE-2021-39537, CVE-2022-29458