Amazon Linux 2:openjpeg2 (ALAS-2022-1894)

medium Nessus Plugin ID 168450

Synopsis

遠端 Amazon Linux 2 主機缺少安全性更新。

描述

遠端主機上安裝的 openjpeg2 版本低於 2.4.0-5。因此,它受到 ALAS2-2022-1894 公告中提及的一個弱點影響。

- 在 openjpeg2 2.4.0 的 opj2_decompress 程式中發現一個缺陷,這個缺陷允許系統處理具有大量檔案的輸入目錄。當無法配置緩衝區以儲存輸入目錄的檔案名稱時,opj2_decompress 程式會在未初始化的指標上呼叫 free(),進而導致分割錯誤和拒絕服務。(CVE-2022-1122)

請注意,Nessus 並未測試此問題,而是僅依據應用程式自我報告的版本號碼作出判斷。

解決方案

執行「yum update openjpeg2」以更新系統。

另請參閱

https://alas.aws.amazon.com/AL2/ALAS-2022-1894.html

https://alas.aws.amazon.com/cve/html/CVE-2022-1122.html

Plugin 詳細資訊

嚴重性: Medium

ID: 168450

檔案名稱: al2_ALAS-2022-1894.nasl

版本: 1.2

類型: local

代理程式: unix

已發布: 2022/12/7

已更新: 2022/12/7

支持的傳感器: Agentless Assessment, Frictionless Assessment Agent, Frictionless Assessment AWS, Nessus Agent

風險資訊

VPR

風險因素: Low

分數: 3.6

CVSS v2

風險因素: Medium

基本分數: 4.3

時間分數: 3.2

媒介: AV:N/AC:M/Au:N/C:N/I:N/A:P

時間媒介: E:U/RL:OF/RC:C

CVSS 評分資料來源: CVE-2022-1122

CVSS v3

風險因素: Medium

基本分數: 5.5

時間分數: 4.8

媒介: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H

時間媒介: E:U/RL:O/RC:C

弱點資訊

CPE: p-cpe:/a:amazon:linux:openjpeg2, p-cpe:/a:amazon:linux:openjpeg2-debuginfo, p-cpe:/a:amazon:linux:openjpeg2-devel, p-cpe:/a:amazon:linux:openjpeg2-devel-docs, p-cpe:/a:amazon:linux:openjpeg2-tools, cpe:/o:amazon:linux:2

必要的 KB 項目: Host/local_checks_enabled, Host/AmazonLinux/release, Host/AmazonLinux/rpm-list

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2022/12/1

弱點發布日期: 2022/3/29

參考資訊

CVE: CVE-2022-1122