Debian DLA-3229-1:node-log4js - LTS 安全性更新

medium Nessus Plugin ID 168447

Synopsis

遠端 Debian 主機缺少與安全性相關的更新。

描述

遠端 Debian 10 主機上安裝的套件受 dla-3229 公告中提及的一個弱點影響。

- log4js-node 是 node.js 的 log4js 連接埠。在受影響的版本中,file、fileSync 和 dateFile 附加器所建立的記錄檔預設權限為任何人皆可讀取 (在 unix 中)。如果記錄檔包含敏感資訊,這可能會造成問題。所有未透過組態中的 mode 參數提供自己的檔案權限的使用者都會受到影響。因此,建議使用者進行更新。
(CVE-2022-21704)

請注意,Nessus 並未測試此問題,而是僅依據應用程式自我報告的版本號碼作出判斷。

解決方案

升級 node-log4js 套件。

針對 Debian 10 buster,已在 4.0.2-2+deb10u1 版中修正此問題。

另請參閱

https://security-tracker.debian.org/tracker/source-package/node-log4js

https://www.debian.org/lts/security/2022/dla-3229

https://security-tracker.debian.org/tracker/CVE-2022-21704

https://packages.debian.org/source/buster/node-log4js

Plugin 詳細資訊

嚴重性: Medium

ID: 168447

檔案名稱: debian_DLA-3229.nasl

版本: 1.2

類型: local

代理程式: unix

已發布: 2022/12/7

已更新: 2022/12/7

支持的傳感器: Agentless Assessment, Frictionless Assessment Agent, Nessus Agent

風險資訊

VPR

風險因素: Medium

分數: 4.4

CVSS v2

風險因素: Low

基本分數: 2.1

時間分數: 1.6

媒介: AV:L/AC:L/Au:N/C:P/I:N/A:N

時間媒介: E:U/RL:OF/RC:C

CVSS 評分資料來源: CVE-2022-21704

CVSS v3

風險因素: Medium

基本分數: 5.5

時間分數: 4.8

媒介: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N

時間媒介: E:U/RL:O/RC:C

弱點資訊

CPE: p-cpe:/a:debian:debian_linux:node-log4js, cpe:/o:debian:debian_linux:10.0

必要的 KB 項目: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2022/12/7

弱點發布日期: 2022/1/19

參考資訊

CVE: CVE-2022-21704