Amazon Linux 2:mutt (ALAS-2022-1892)

medium Nessus Plugin ID 168438

Synopsis

遠端 Amazon Linux 2 主機缺少安全性更新。

描述

遠端主機上安裝的 mutt 版本低於 1.5.21-29。因此,會受到 ALAS2-2022-1892 公告中所提及的多個弱點影響。

- Mutt 1.14.3 之前版本允許透過 PREAUTH 回應發動 IMAP fcc/postpone 攔截式攻擊。
(CVE-2020-14093)

- 即使使用者在回應 GnuTLS 憑證提示時拒絕了過期的中繼憑證,1.14.3 之前的 Mutt 仍會繼續進行連線。(CVE-2020-14154)

- 1.14.4 之前的 Mutt 和 2020-06-19 之前的 NeoMutt 存在 STARTTLS 緩衝問題,此問題會影響 IMAP、SMTP 和 POP3。當伺服器傳送開始 TLS 回應時,用戶端會讀取其他資料 (例如,來自攔截式攻擊者的資料) 並在 TLS 內容中進行評估,亦即回應插入。(CVE-2020-14954)

- 如果 IMAP 伺服器的初始回應無效,則 Mutt 2.0.2 之前的版本和 2020 年 11 月 20 日之前的 NeoMutt 版本無法確保處理 $ssl_force_tls。未正確關閉連線,因此程式碼可繼續嘗試驗證。這可導致驗證憑證透過未加密的連線洩漏,或洩漏給中間機器。(CVE-2020-28896)

- Mutt 2.0.4 版以及之前的所有版本中,rfc822.c 允許遠端攻擊者傳送 RFC822 位址欄位中含有分號字元序列的電子郵件訊息,造成拒絕服務 (信箱無法使用),即空白群組的終止字元。來自攻擊者的小電子郵件訊息可造成大量記憶體消耗,受害者可能無法再看到其他人的電子郵件訊息。(CVE-2021-3181)

- Mutt 的 uudecoder 中的緩衝區溢位弱點允許讀取超出輸入行結尾的內容,此弱點會影響 Mutt 0.94.13 至 2.2.3 之間的所有版本 (CVE-2022-1328)

請注意,Nessus 並未測試這些問題,而是僅依據應用程式自我報告的版本號碼作出判斷。

解決方案

執行「yum update mutt」以更新系統。

另請參閱

https://alas.aws.amazon.com/AL2/ALAS-2022-1892.html

https://alas.aws.amazon.com/cve/html/CVE-2020-14093.html

https://alas.aws.amazon.com/cve/html/CVE-2020-14154.html

https://alas.aws.amazon.com/cve/html/CVE-2020-14954.html

https://alas.aws.amazon.com/cve/html/CVE-2020-28896.html

https://alas.aws.amazon.com/cve/html/CVE-2021-3181.html

https://alas.aws.amazon.com/cve/html/CVE-2022-1328.html

Plugin 詳細資訊

嚴重性: Medium

ID: 168438

檔案名稱: al2_ALAS-2022-1892.nasl

版本: 1.3

類型: local

代理程式: unix

已發布: 2022/12/7

已更新: 2022/12/7

支持的傳感器: Agentless Assessment, Frictionless Assessment Agent, Frictionless Assessment AWS, Nessus Agent

風險資訊

VPR

風險因素: Low

分數: 3.6

CVSS v2

風險因素: Medium

基本分數: 5.8

時間分數: 4.5

媒介: AV:N/AC:M/Au:N/C:P/I:P/A:N

時間媒介: E:POC/RL:OF/RC:C

CVSS 評分資料來源: CVE-2020-14154

CVSS v3

風險因素: Medium

基本分數: 5.9

時間分數: 5.3

媒介: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N

時間媒介: E:P/RL:O/RC:C

CVSS 評分資料來源: CVE-2020-14954

弱點資訊

CPE: p-cpe:/a:amazon:linux:mutt, p-cpe:/a:amazon:linux:mutt-debuginfo, cpe:/o:amazon:linux:2

必要的 KB 項目: Host/local_checks_enabled, Host/AmazonLinux/release, Host/AmazonLinux/rpm-list

可被惡意程式利用: true

可輕鬆利用: Exploits are available

修補程式發佈日期: 2022/12/1

弱點發布日期: 2020/6/15

參考資訊

CVE: CVE-2020-14093, CVE-2020-14154, CVE-2020-14954, CVE-2020-28896, CVE-2021-3181, CVE-2022-1328