Debian DLA-3224-1:http-parser - LTS 安全性更新

medium Nessus Plugin ID 168405

Synopsis

遠端 Debian 主機缺少與安全性相關的更新。

描述

遠端 Debian 10 主機上安裝的多個套件受到 dla-3224 公告中提及的一個弱點影響。

10.23.1、12.20.1、14.15.4、15.5.1 之前的 Node.js 版本允許 HTTP 要求中存在兩個標頭欄位副本,例如兩個 Transfer-Encoding 標頭欄位。在此情況下,Node.js 會識別第一個標頭欄位,並忽略第二個標頭欄位。這可導致 HTTP 要求走私。(CVE-2020-8287)

請注意,Nessus 並未測試此問題,而是僅依據應用程式自我報告的版本號碼作出判斷。

解決方案

升級 http-parser 套件。

針對 Debian 10 Buster,已在 2.8.1-1+deb10u3 版中修正此問題。

另請參閱

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=1016690

https://security-tracker.debian.org/tracker/source-package/http-parser

https://www.debian.org/lts/security/2022/dla-3224

https://security-tracker.debian.org/tracker/CVE-2020-8287

https://packages.debian.org/source/buster/http-parser

Plugin 詳細資訊

嚴重性: Medium

ID: 168405

檔案名稱: debian_DLA-3224.nasl

版本: 1.2

類型: local

代理程式: unix

已發布: 2022/12/5

已更新: 2022/12/5

支持的傳感器: Frictionless Assessment Agent, Nessus Agent, Agentless Assessment

風險資訊

VPR

風險因素: Low

分數: 3.3

CVSS v2

風險因素: Medium

基本分數: 6.4

時間分數: 4.7

媒介: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:N

時間媒介: CVSS2#E:U/RL:OF/RC:C

CVSS 評分資料來源: CVE-2020-8287

CVSS v3

風險因素: Medium

基本分數: 6.5

時間分數: 5.7

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N

時間媒介: CVSS:3.0/E:U/RL:O/RC:C

弱點資訊

CPE: cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:*, p-cpe:2.3:a:debian:debian_linux:libhttp-parser-dev:*:*:*:*:*:*:*, p-cpe:2.3:a:debian:debian_linux:libhttp-parser2.8:*:*:*:*:*:*:*

必要的 KB 項目: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2022/12/5

弱點發布日期: 2021/1/4

參考資訊

CVE: CVE-2020-8287