Debian DSA-5293-1:chromium - 安全性更新

high Nessus Plugin ID 168402

Synopsis

遠端 Debian 主機上缺少一個或多個安全性更新。

描述

遠端 Debian 11 主機上安裝的多個套件受到 dsa-5293 公告中提及的多個弱點影響。

- 在 Google Chrome 108.0.5359.71 之前的版本中,V8 中存在類型混淆弱點,因此遠端攻擊者可透過建構的 HTML 頁面引致堆積損毀。(Chromium 安全性嚴重性:高) (CVE-2022-4174)

- 在 Google Chrome 108.0.5359.71 之前的版本中,螢幕擷取中存在釋放後使用問題,因此遠端攻擊者可透過建構的 HTML 頁面惡意引致堆積損毀。(Chromium 安全性嚴重性:高) (CVE-2022-4175)

- 在 Chrome OS 版 Google Chrome 和 Lacros 108.0.5359.71之前的版本中,Lacros Graphics 中存在超出邊界寫入弱點,成功誘騙使用者參與特定 UI 互動的遠端攻擊者可能利用此弱點,透過 UI 互動造成堆積損毀。(Chromium 安全性嚴重性:高) (CVE-2022-4176)

- 在 Google Chrome 108.0.5359.71 之前的版本中,延伸模組中存在釋放後使用弱點,成功誘騙使用者安裝延伸模組的攻擊者可能藉此透過建構的 Chrome 延伸模組和 UI 互動造成堆積損毀。(Chromium 安全性嚴重性:高) (CVE-2022-4177)

- 在 Google Chrome 108.0.5359.71 之前的版本中,Mojo 中存在釋放後使用問題,已入侵轉譯器處理序的遠端攻擊者可能利用此問題,透過建構的 HTML 頁面造成堆積損毀。(Chromium 安全性嚴重性:高) (CVE-2022-4178)

- 在 Google Chrome 108.0.5359.71 之前的版本中,音訊中存在釋放後使用弱點,成功誘騙使用者安裝惡意延伸模組的攻擊者可能利用此弱點,透過建構的 Chrome 延伸模組造成堆積損毀。
(Chromium 安全性嚴重性:高) (CVE-2022-4179)

- 在 Google Chrome 108.0.5359.71 之前的版本中,Mojo 中存在釋放後使用弱點,成功誘騙使用者安裝惡意延伸模組的攻擊者可能利用此弱點,透過建構的 Chrome 延伸模組造成堆積損毀。
(Chromium 安全性嚴重性:高) (CVE-2022-4180)

- 在 Google Chrome 108.0.5359.71 之前的版本中,表單中存在釋放後使用問題,遠端攻擊者可能利用此問題,透過建構的 HTML 頁面造成堆積損毀。(Chromium 安全性嚴重性:高) (CVE-2022-4181)

- 在 Google Chrome 108.0.5359.71 之前的版本中, Fenced Frames 中存在實作不當弱點,此弱點允許遠端攻擊者透過建構的 HTML 頁面,繞過框架隔離。(Chromium 安全性嚴重性:中) (CVE-2022-4182)

- 在 Google Chrome 108.0.5359.71 之前的版本中,Popup Blocker 中存在原則強制執行不充分問題,遠端攻擊者可藉此透過建構的 HTML 頁面繞過導覽限制。(Chromium 安全性嚴重性:中) (CVE-2022-4183)

- 在 Google Chrome 108.0.5359.71 之前的版本中,Autofill 中存在原則強制執行不充分問題,遠端攻擊者可藉此透過建構的 HTML 頁面繞過自動填滿限制。(Chromium 安全性嚴重性:中) (CVE-2022-4184)

- 在 iOS 版 Google Chrome 108.0.5359.71 之前的版本中, Navigation 中存在不當實作問題,遠端攻擊者可藉此透過建構的 HTML 頁面僞造模態對話的內容。(Chromium 安全性嚴重性:
中) (CVE-2022-4185)

- 在 Google Chrome 108.0.5359.71 之前的版本中,下載中存在對於不受信任的輸入驗證不充分的弱點,成功誘騙使用者安裝惡意延伸模組的攻擊者可利用此弱點,透過建構的 HTML 頁面繞過下載限制。(Chromium 安全性嚴重性:中) (CVE-2022-4186)

- 在 Google Chrome 108.0.5359.71 之前的版本中,DevTools 中存在原則強制執行不充分問題,遠端攻擊者可藉此透過建構的 HTML 頁面繞過檔案系統限制。(Chromium 安全性嚴重性:
中) (CVE-2022-4187)

- 在 Google Chrome 108.0.5359.71 之前的版本中,CORS 中存在對不受信任的輸入驗證不足的弱點,此弱點允許遠端攻擊者透過構建的 HTML 頁面繞過相同原始原則。(Chromium 安全性嚴重性:中) (CVE-2022-4188)

- 在 Google Chrome 108.0.5359.71 之前的版本中,DevTools 中存在實作不當弱點,此弱點允許已誘騙使用者安裝惡意延伸模組的攻擊者透過建構的 Chrome 延伸模組繞過導覽限制。(Chromium 安全性嚴重性:中) (CVE-2022-4189)

- 在 Google Chrome 108.0.5359.71 之前的版本中,Directory 中存在資料驗證不充分問題,遠端攻擊者可藉此透過建構的 HTML 頁面繞過檔案系統限制。(Chromium 安全性嚴重性:中) (CVE-2022-4190)

- 在 Google Chrome 108.0.5359.71 之前的版本中,在 Sign-In 中存在釋放後使用弱點,成功誘騙使用者參與特定 UI 互動的遠端攻擊者可能藉此透過設定檔解構造成堆積損毀。(Chromium 安全性嚴重性:中) (CVE-2022-4191)

- 在 Google Chrome 108.0.5359.71 之前的版本中,在 Live Caption 中存在釋放後使用弱點,成功誘騙使用者參與特定 UI 互動的遠端攻擊者可能藉此透過 UI 互動引致堆積損毀。(Chromium 安全性嚴重性:中) (CVE-2022-4192)

- 在 Google Chrome 108.0.5359.71 之前的版本中,在 File System API 中存在原則強制執行不充分問題,遠端攻擊者可藉此透過建構的 HTML 頁面繞過檔案系統限制。(Chromium 安全性嚴重性:
中) (CVE-2022-4193)

- 在 Google Chrome 108.0.5359.71 之前的版本中,Accessibility 中存在釋放後使用問題,遠端攻擊者可透過建構的 HTML 頁面惡意引致堆積損毀。(Chromium 安全性嚴重性:中) (CVE-2022-4194)

- 在 Google Chrome 108.0.5359.71 之前的版本中,安全瀏覽功能中存在原則強制執行不足問題,遠端攻擊者可藉此透過惡意檔案繞過安全瀏覽警告。(Chromium 安全性嚴重性:中) (CVE-2022-4195)

請注意,Nessus 並未測試這些問題,而是僅依據應用程式自我報告的版本號碼作出判斷。

解決方案

升級 chromium 套件。

針對穩定的發行版本 (bullseye),已在 108.0.5359.71-2~deb11u1 版本中修正這些問題。

另請參閱

https://security-tracker.debian.org/tracker/source-package/chromium

https://www.debian.org/security/2022/dsa-5293

https://security-tracker.debian.org/tracker/CVE-2022-4174

https://security-tracker.debian.org/tracker/CVE-2022-4175

https://security-tracker.debian.org/tracker/CVE-2022-4176

https://security-tracker.debian.org/tracker/CVE-2022-4177

https://security-tracker.debian.org/tracker/CVE-2022-4178

https://security-tracker.debian.org/tracker/CVE-2022-4179

https://security-tracker.debian.org/tracker/CVE-2022-4180

https://security-tracker.debian.org/tracker/CVE-2022-4181

https://security-tracker.debian.org/tracker/CVE-2022-4182

https://security-tracker.debian.org/tracker/CVE-2022-4183

https://security-tracker.debian.org/tracker/CVE-2022-4184

https://security-tracker.debian.org/tracker/CVE-2022-4185

https://security-tracker.debian.org/tracker/CVE-2022-4186

https://security-tracker.debian.org/tracker/CVE-2022-4187

https://security-tracker.debian.org/tracker/CVE-2022-4188

https://security-tracker.debian.org/tracker/CVE-2022-4189

https://security-tracker.debian.org/tracker/CVE-2022-4190

https://security-tracker.debian.org/tracker/CVE-2022-4191

https://security-tracker.debian.org/tracker/CVE-2022-4192

https://security-tracker.debian.org/tracker/CVE-2022-4193

https://security-tracker.debian.org/tracker/CVE-2022-4194

https://security-tracker.debian.org/tracker/CVE-2022-4195

https://packages.debian.org/source/bullseye/chromium

Plugin 詳細資訊

嚴重性: High

ID: 168402

檔案名稱: debian_DSA-5293.nasl

版本: 1.3

類型: local

代理程式: unix

已發布: 2022/12/5

已更新: 2023/1/6

支持的傳感器: Agentless Assessment, Frictionless Assessment Agent, Nessus Agent

風險資訊

VPR

風險因素: Medium

分數: 6.7

CVSS v2

風險因素: Critical

基本分數: 10

時間分數: 7.8

媒介: AV:N/AC:L/Au:N/C:C/I:C/A:C

時間媒介: E:POC/RL:OF/RC:C

CVSS 評分資料來源: CVE-2022-4194

CVSS v3

風險因素: High

基本分數: 8.8

時間分數: 7.9

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

時間媒介: E:P/RL:O/RC:C

弱點資訊

CPE: p-cpe:/a:debian:debian_linux:chromium, p-cpe:/a:debian:debian_linux:chromium-common, p-cpe:/a:debian:debian_linux:chromium-driver, p-cpe:/a:debian:debian_linux:chromium-l10n, p-cpe:/a:debian:debian_linux:chromium-sandbox, p-cpe:/a:debian:debian_linux:chromium-shell, cpe:/o:debian:debian_linux:11.0

必要的 KB 項目: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

可被惡意程式利用: true

可輕鬆利用: Exploits are available

修補程式發佈日期: 2022/12/3

弱點發布日期: 2022/11/29

參考資訊

CVE: CVE-2022-4174, CVE-2022-4175, CVE-2022-4176, CVE-2022-4177, CVE-2022-4178, CVE-2022-4179, CVE-2022-4180, CVE-2022-4181, CVE-2022-4182, CVE-2022-4183, CVE-2022-4184, CVE-2022-4185, CVE-2022-4186, CVE-2022-4187, CVE-2022-4188, CVE-2022-4189, CVE-2022-4190, CVE-2022-4191, CVE-2022-4192, CVE-2022-4193, CVE-2022-4194, CVE-2022-4195