Debian DLA-3210-1:gmp - LTS 安全性更新

high Nessus Plugin ID 168260

Synopsis

遠端 Debian 主機上缺少一個或多個安全性更新。

描述

遠端 Debian 10 主機上安裝的一個套件受到 dla-3210 公告中提及的多個弱點影響。

- Gerbv 2.7.0 和 dev (commit b5f1eacd) 以及 Gerbv 分支 2.7.1 的 RS-274X 範圍定義標記化功能中存在釋放後使用弱點。特製的 gerber 檔案可導致程式碼執行。攻擊者可能透過提供惡意檔案,來觸發此弱點。(CVE-2021-40401)

- Gerbv 2.7.0 和 dev (commit b5f1eacd) 以及 Gerbv 分支 2.8.0 的取放旋轉剖析功能中存在資訊洩漏弱點。特製的取放檔案可利用結構初始化缺失來洩漏記憶體內容。攻擊者可能透過提供惡意檔案,來觸發此弱點。(CVE-2021-40403)

請注意,Nessus 並未測試這些問題,而是僅依據應用程式自我報告的版本號碼作出判斷。

解決方案

升級 gerbv 套件。

針對 Debian 10 Buster,已在 2.7.0-1+deb10u2 版本中修正這些問題。

另請參閱

https://www.debian.org/lts/security/2022/dla-3210

https://security-tracker.debian.org/tracker/CVE-2021-40401

https://security-tracker.debian.org/tracker/CVE-2021-40403

https://packages.debian.org/source/buster/gerbv

Plugin 詳細資訊

嚴重性: High

ID: 168260

檔案名稱: debian_DLA-3210.nasl

版本: 1.2

類型: local

代理程式: unix

已發布: 2022/11/29

已更新: 2022/11/29

支持的傳感器: Agentless Assessment, Frictionless Assessment Agent, Nessus Agent

風險資訊

VPR

風險因素: Medium

分數: 6.5

CVSS v2

風險因素: Medium

基本分數: 6.8

時間分數: 5

媒介: AV:N/AC:M/Au:N/C:P/I:P/A:P

時間媒介: E:U/RL:OF/RC:C

CVSS 評分資料來源: CVE-2021-40401

CVSS v3

風險因素: High

基本分數: 8.6

時間分數: 7.5

媒介: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H

時間媒介: E:U/RL:O/RC:C

弱點資訊

CPE: p-cpe:/a:debian:debian_linux:gerbv, cpe:/o:debian:debian_linux:10.0

必要的 KB 項目: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2022/11/28

弱點發布日期: 2022/2/4

參考資訊

CVE: CVE-2021-40401, CVE-2021-40403