Oracle Linux 8:varnish:6 (ELSA-2022-8649)

high Nessus Plugin ID 168226

Synopsis

遠端 Oracle Linux 主機缺少安全性更新。

描述

遠端 Oracle Linux 8 主機上安裝的套件受到 ELSA-2022-8649 公告中提及的一個弱點影響。

- 在 5.x 版、低於 6.0.11 的 6.x 版、低於 7.1.2 的 7.x 版、低於 7.2.1 的 7.2.x 版的 Varnish Cache 中發現一個 HTTP 要求偽造問題。攻擊者可透過在 HTTP/1 要求行內容中無效的 HTTP/2 偽標頭引入字元,進而造成 Varnish 伺服器產生對後端無效的 HTTP/1 要求。反過來,攻擊者可藉機惡意利用 Varnish 伺服器後的伺服器弱點。注意: 6.0.x LTS 系列 (低於 6.0.11 版) 受到影響。(CVE-2022-45060)

請注意,Nessus 並未測試此問題,而是僅依據應用程式自我報告的版本號碼作出判斷。

解決方案

更新受影響的套件。

另請參閱

https://linux.oracle.com/errata/ELSA-2022-8649.html

Plugin 詳細資訊

嚴重性: High

ID: 168226

檔案名稱: oraclelinux_ELSA-2022-8649.nasl

版本: 1.2

類型: local

代理程式: unix

已發布: 2022/11/28

已更新: 2022/11/28

支持的傳感器: Frictionless Assessment Agent, Nessus Agent

風險資訊

VPR

風險因素: Medium

分數: 4.4

CVSS v2

風險因素: High

基本分數: 7.8

時間分數: 5.8

媒介: CVSS2#AV:N/AC:L/Au:N/C:N/I:C/A:N

時間媒介: CVSS2#E:U/RL:OF/RC:C

CVSS 評分資料來源: CVE-2022-45060

CVSS v3

風險因素: High

基本分數: 7.5

時間分數: 6.5

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N

時間媒介: CVSS:3.0/E:U/RL:O/RC:C

弱點資訊

CPE: cpe:2.3:o:oracle:linux:8:*:*:*:*:*:*:*, p-cpe:2.3:a:oracle:linux:varnish:*:*:*:*:*:*:*, p-cpe:2.3:a:oracle:linux:varnish-devel:*:*:*:*:*:*:*, p-cpe:2.3:a:oracle:linux:varnish-docs:*:*:*:*:*:*:*, p-cpe:2.3:a:oracle:linux:varnish-modules:*:*:*:*:*:*:*

必要的 KB 項目: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list, Host/OracleLinux

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2022/11/28

弱點發布日期: 2022/11/9

參考資訊

CVE: CVE-2022-45060