Debian DLA-3208-1:varnish - LTS 安全性更新

high Nessus Plugin ID 168207

Synopsis

遠端 Debian 主機上缺少一個或多個安全性更新。

描述

遠端 Debian 10 主機上安裝的多個套件受到 dla-3208 公告中提及的多個弱點影響。

- 在 6.0.6 LTS 之前、6.2.3 之前的 6.1.x 和 6.2.x、6.3.2 之前的 6.3.x 版本的 Varnish Cache 中發現一個問題。與 TLS 終止代理的通訊使用 PROXY 版本 2 時會發生此問題。可能存在宣告失敗和程序重新啟動,進而造成效能降低。(CVE-2020-11653)

- 在 5.x 版、低於 6.0.11 的 6.x 版、低於 7.1.2 的 7.x 版、低於 7.2.1 的 7.2.x 版的 Varnish Cache 中發現一個 HTTP 要求偽造問題。攻擊者可透過在 HTTP/1 要求行內容中無效的 HTTP/2 偽標頭引入字元,進而造成 Varnish 伺服器產生對後端無效的 HTTP/1 要求。反過來,攻擊者可藉機惡意利用 Varnish 伺服器後的伺服器弱點。注意: 6.0.x LTS 系列 (低於 6.0.11 版) 受到影響。(CVE-2022-45060)

請注意,Nessus 並未測試這些問題,而是僅依據應用程式自我報告的版本號碼作出判斷。

解決方案

升級 varnish 套件。

針對 Debian 10 buster,已在 6.1.1-1+deb10u4 版中修正這些問題。

另請參閱

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=956307

https://security-tracker.debian.org/tracker/source-package/varnish

https://www.debian.org/lts/security/2022/dla-3208

https://security-tracker.debian.org/tracker/CVE-2020-11653

https://security-tracker.debian.org/tracker/CVE-2022-45060

https://packages.debian.org/source/buster/varnish

Plugin 詳細資訊

嚴重性: High

ID: 168207

檔案名稱: debian_DLA-3208.nasl

版本: 1.2

類型: local

代理程式: unix

已發布: 2022/11/27

已更新: 2022/11/27

支持的傳感器: Agentless Assessment, Frictionless Assessment Agent, Nessus Agent

風險資訊

VPR

風險因素: Medium

分數: 4.4

CVSS v2

風險因素: Medium

基本分數: 5

時間分數: 3.7

媒介: AV:N/AC:L/Au:N/C:N/I:N/A:P

時間媒介: E:U/RL:OF/RC:C

CVSS 評分資料來源: CVE-2020-11653

CVSS v3

風險因素: High

基本分數: 7.5

時間分數: 6.5

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N

時間媒介: E:U/RL:O/RC:C

CVSS 評分資料來源: CVE-2022-45060

弱點資訊

CPE: p-cpe:/a:debian:debian_linux:libvarnishapi-dev, p-cpe:/a:debian:debian_linux:libvarnishapi2, p-cpe:/a:debian:debian_linux:varnish, p-cpe:/a:debian:debian_linux:varnish-doc, cpe:/o:debian:debian_linux:10.0

必要的 KB 項目: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2022/11/27

弱點發布日期: 2020/4/8

參考資訊

CVE: CVE-2020-11653, CVE-2022-45060