Samba < 4.15.12、 4.16.x < 4.16.7和 4.17.x < 4.17.3 32 位元系統緩衝區溢位

high Nessus Plugin ID 168018

Synopsis

遠端 Samba 伺服器可能受到緩衝區溢位弱點影響

描述

遠端主機上執行的 Samba 為 4.15.12 之前版本、4.16.7 之前的 4.16.x 版,或 4.17.3 之前的 4.17.x 版。
因此,它可能受到隨附的 Kerberos 庫中的緩衝區溢位弱點影響,這是因為未計算要爲緩衝區配置的位元組。經驗證的遠端攻擊者可利用此弱點,透過含有權限屬性憑證的特製票證造成拒絕服務情形或超出記憶體邊界讀取。

請注意,Nessus 並未測試這些問題,而是僅依據應用程式自我報告的版本號碼作出判斷。

解決方案

升級至 Samba 4.15.12、4.16.7、4.17.3 或更新版本。

另請參閱

https://www.samba.org/samba/security/CVE-2022-42898.html

Plugin 詳細資訊

嚴重性: High

ID: 168018

檔案名稱: samba_cve_2022-42898.nasl

版本: 1.4

類型: remote

系列: Misc.

已發布: 2022/11/21

已更新: 2023/1/6

風險資訊

VPR

風險因素: Medium

分數: 6.7

CVSS v2

風險因素: High

基本分數: 9

時間分數: 6.7

媒介: CVSS2#AV:N/AC:L/Au:S/C:C/I:C/A:C

時間媒介: CVSS2#E:U/RL:OF/RC:C

CVSS 評分資料來源: CVE-2022-42898

CVSS v3

風險因素: High

基本分數: 8.8

時間分數: 7.7

媒介: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

時間媒介: CVSS:3.0/E:U/RL:O/RC:C

弱點資訊

CPE: cpe:2.3:a:samba:samba:*:*:*:*:*:*:*:*

必要的 KB 項目: SMB/samba, SMB/NativeLanManager

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2022/11/15

弱點發布日期: 2022/11/15

參考資訊

CVE: CVE-2022-42898

IAVA: 2022-A-0495-S