Debian DLA-3195-1:jupyter-core - LTS 安全性更新

high Nessus Plugin ID 167914

Synopsis

遠端 Debian 主機缺少安全性相關更新。

描述

遠端 Debian 10 主機上安裝的多個套件受到 dla-3195 公告中提及的一個弱點影響。

- Jupyter Core 是 Jupyter 專案的核心通用功能套件。在 4.11.2 版之前的 Jupyter Core 中,因為 jupyter_core 在 CWD 中執行未受信任的檔案,造成 jupyter_core 中包含任意程式碼執行弱點。此弱點允許使用者以另一位使用者的身分執行程式碼。 4.11.2 版包含針對此問題的修補程式。目前尚無已知的因應措施。(CVE-2022-39286)

請注意,Nessus 並未測試此問題,而是僅依據應用程式自我報告的版本號碼作出判斷。

解決方案

升級 jupyter-core 套件。

針對 Debian 10 buster,已在 4.4.0-2+deb10u1 版中修正此問題。

另請參閱

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=1023361

http://www.nessus.org/u?80a0526b

https://www.debian.org/lts/security/2022/dla-3195

https://security-tracker.debian.org/tracker/CVE-2022-39286

https://packages.debian.org/source/buster/jupyter-core

Plugin 詳細資訊

嚴重性: High

ID: 167914

檔案名稱: debian_DLA-3195.nasl

版本: 1.3

類型: local

代理程式: unix

已發布: 2022/11/18

已更新: 2022/11/24

支持的傳感器: Agentless Assessment, Frictionless Assessment Agent, Nessus Agent

風險資訊

VPR

風險因素: Medium

分數: 6.7

CVSS v2

風險因素: High

基本分數: 9

時間分數: 6.7

媒介: AV:N/AC:L/Au:S/C:C/I:C/A:C

時間媒介: E:U/RL:OF/RC:C

CVSS 評分資料來源: CVE-2022-39286

CVSS v3

風險因素: High

基本分數: 8.8

時間分數: 7.7

媒介: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

時間媒介: E:U/RL:O/RC:C

弱點資訊

CPE: p-cpe:/a:debian:debian_linux:jupyter, p-cpe:/a:debian:debian_linux:jupyter-core, p-cpe:/a:debian:debian_linux:python-jupyter-core, p-cpe:/a:debian:debian_linux:python-jupyter-core-doc, p-cpe:/a:debian:debian_linux:python3-jupyter-core, cpe:/o:debian:debian_linux:10.0

必要的 KB 項目: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2022/11/17

弱點發布日期: 2022/10/26

參考資訊

CVE: CVE-2022-39286