Ubuntu 18.04 LTS / 20.04 LTS / 22.04 LTS / 22.10:multipath-tools 弱點 (USN-5731-1)

high Nessus Plugin ID 167900

Synopsis

遠端 Ubuntu 主機缺少一個或多個安全性更新。

描述

遠端 Ubuntu 18.04 LTS/20.04 LTS/22.04 LTS/22.10 主機上安裝的套件受到 USN-5731-1 公告中所提及的多個弱點影響。

- multipath-tools 0.7.7 版至 0.9.2 之前的 0.9.x 版允許本機使用者取得 root 存取權,此弱點可以與 CVE-2022-41974 結合利用。由於不正確的符號連結處理,能夠存取 /dev/shm 的本機使用者可變更 multipathd 中的符號連結,這可導致在 /dev/shm 目錄之外寫入受控制的檔案。攻擊者可間接利用此弱點將本機權限提升至 root 權限。(CVE-2022-41973)

- multipath-tools 0.7.0 版至 0.9.2 之前的 0.9.x 版允許本機使用者取得 root 存取權,此弱點可以單獨利用或與 CVE-2022-41973 結合利用。能夠寫入 UNIX 網域通訊端的本機使用者可繞過存取控制並操控 multipath 設定。這可導致本機權限提升至 root 權限。
這是因為攻擊者可以重複因使用算術 ADD 而非按位元 OR 而導致錯誤處理的關鍵字。(CVE-2022-41974)

請注意,Nessus 並未測試這些問題,而是僅依據應用程式自我報告的版本號碼作出判斷。

解決方案

更新受影響的套件。

另請參閱

https://ubuntu.com/security/notices/USN-5731-1

Plugin 詳細資訊

嚴重性: High

ID: 167900

檔案名稱: ubuntu_USN-5731-1.nasl

版本: 1.5

類型: local

代理程式: unix

已發布: 2022/11/18

已更新: 2023/1/17

支持的傳感器: Agentless Assessment, Frictionless Assessment Agent, Frictionless Assessment AWS, Frictionless Assessment Azure, Nessus Agent

風險資訊

VPR

風險因素: High

分數: 7.4

CVSS v2

風險因素: Medium

基本分數: 6.8

時間分數: 5.3

媒介: AV:L/AC:L/Au:S/C:C/I:C/A:C

時間媒介: E:POC/RL:OF/RC:C

CVSS 評分資料來源: CVE-2022-41974

CVSS v3

風險因素: High

基本分數: 7.8

時間分數: 7

媒介: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

時間媒介: E:P/RL:O/RC:C

弱點資訊

CPE: cpe:/o:canonical:ubuntu_linux:18.04:-:lts, cpe:/o:canonical:ubuntu_linux:20.04:-:lts, cpe:/o:canonical:ubuntu_linux:22.04:-:lts, cpe:/o:canonical:ubuntu_linux:22.10, p-cpe:/a:canonical:ubuntu_linux:kpartx, p-cpe:/a:canonical:ubuntu_linux:kpartx-boot, p-cpe:/a:canonical:ubuntu_linux:multipath-tools, p-cpe:/a:canonical:ubuntu_linux:multipath-tools-boot

必要的 KB 項目: Host/cpu, Host/Ubuntu, Host/Ubuntu/release, Host/Debian/dpkg-l

可被惡意程式利用: true

可輕鬆利用: Exploits are available

修補程式發佈日期: 2022/11/17

弱點發布日期: 2022/10/25

參考資訊

CVE: CVE-2022-41973, CVE-2022-41974

USN: 5731-1