RHEL 9:buildah (RHSA-2022: 8008)

high Nessus Plugin ID 167618

概要

遠端 Red Hat 主機缺少一個或多個安全性更新。

說明

遠端 Redhat Enterprise Linux 9 主機上安裝的套件受到 RHSA-2022: 8008 公告中提及的多個弱點影響。

- container/storage:透過惡意影像造成 DoS (CVE-2021-20291)

- golang:net:查詢函式可能傳回無效的主機名稱 (CVE-2021-33195)

- golang:net/http/httputil:如果第一個標頭為空,ReverseProxy 會轉送連線標頭 (CVE-2021-33197)

- golang:math/big.Rat:如果傳遞具有很大指數的輸入,可能會造成不穩定或無法復原的嚴重錯誤 (CVE-2021-33198)

- 適用於 Go 的 golang.org/x/crypto/ssh 套件 0.0.0-20220314234659-1baeb1ce4c0b 之前版本在涉及 AddHostKey 的某些情況下允許攻擊者造成伺服器當機。(CVE-2022-27191)

- Podman 容器引擎中存在附加群組處理不正確問題,這可能導致敏感資訊洩漏或資料修改,但前提是攻擊者可以直接存取受影響的容器 (其中使用附加群組來設定存取權限,並且附加群組能夠在此容器中執行二進位程式碼)。(CVE-2022-2989)

- Buildah 容器引擎中存在附加群組處理不正確問題,這可能導致敏感資訊洩漏或資料修改,但前提是攻擊者可以直接存取受影響的容器 (其中使用附加群組來設定存取權限,並且附加群組能夠在此容器中執行二進位檔)。(CVE-2022-2990)

請注意,Nessus 並未測試這些問題,而是僅依據應用程式自我報告的版本號碼作出判斷。

解決方案

更新受影響的 buildah 和/或 buildah-tests 套件。

另請參閱

https://access.redhat.com/security/cve/CVE-2021-20291

https://access.redhat.com/security/cve/CVE-2021-33195

https://access.redhat.com/security/cve/CVE-2021-33197

https://access.redhat.com/security/cve/CVE-2021-33198

https://access.redhat.com/security/cve/CVE-2022-2989

https://access.redhat.com/security/cve/CVE-2022-2990

https://access.redhat.com/security/cve/CVE-2022-27191

https://access.redhat.com/errata/RHSA-2022:8008

https://bugzilla.redhat.com/1939485

https://bugzilla.redhat.com/1989564

https://bugzilla.redhat.com/1989570

https://bugzilla.redhat.com/1989575

Plugin 詳細資訊

嚴重性: High

ID: 167618

檔案名稱: redhat-RHSA-2022-8008.nasl

版本: 1.5

類型: local

代理程式: unix

已發布: 2022/11/16

已更新: 2023/10/3

支援的感應器: Agentless Assessment, Frictionless Assessment Agent, Frictionless Assessment AWS, Frictionless Assessment Azure, Nessus Agent, Nessus

風險資訊

VPR

風險因素: Medium

分數: 6.0

CVSS v2

風險因素: High

基本分數: 7.5

時間分數: 5.9

媒介: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

CVSS 評分資料來源: CVE-2021-33195

CVSS v3

風險因素: High

基本分數: 7.3

時間分數: 6.6

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

時間媒介: CVSS:3.0/E:P/RL:O/RC:C

弱點資訊

CPE: cpe:/o:redhat:enterprise_linux:9, cpe:/o:redhat:rhel_aus:9.2, cpe:/o:redhat:rhel_e4s:9.2, cpe:/o:redhat:rhel_eus:9.2, p-cpe:/a:redhat:enterprise_linux:buildah, p-cpe:/a:redhat:enterprise_linux:buildah-tests

必要的 KB 項目: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list, Host/cpu

可被惡意程式利用: true

可輕鬆利用: Exploits are available

修補程式發佈日期: 2022/11/15

弱點發布日期: 2021/4/1

參考資訊

CVE: CVE-2021-20291, CVE-2021-33195, CVE-2021-33197, CVE-2021-33198, CVE-2022-27191, CVE-2022-2989, CVE-2022-2990

CWE: 20, 327, 400, 667, 842

RHSA: 2022:8008