Debian DSA-5277-1:php7.4 - 安全性更新

critical Nessus Plugin ID 167434

概要

遠端 Debian 主機上缺少一個或多個安全性更新。

說明

遠端 Debian 11 主機上安裝的多個套件受到 dsa-5277 公告中提及的多個弱點影響。

- 在 PHP 7.4.31 之前版本、8.0.24 和 8.1.11 版中,phar 解壓縮程式碼會以遞回方式解壓縮 quines gzip 檔案,進而導致無限迴圈。(CVE-2022-31628)

- 在 PHP 7.4.31 之前版本、8.0.24 和 8.1.11 版中,網路和相同網站的攻擊者可利用此弱點在受害者的瀏覽器中設定標準的不安全 Cookie,而 PHP 應用程式會將其視為「__Host-」或「__Secure-」Cookie。(CVE-2022-31629)

- 在 fdc6fef 之前的 Keccak XKCP SHA-3 參照實作中發現整數溢位問題和由此產生的緩衝區溢位,攻擊者可以藉此執行任意程式碼或消除預期的密碼編譯屬性。
這問題發生在 sponge 函式介面中。(CVE-2022-37454)

此弱點是由 imageloadfont() 函式中的邊界條件造成。遠端攻擊者可將特製的資料傳送至 Web 應用程式,觸發超出邊界讀取錯誤並讀取系統上的記憶體內容。(CVE-2022-31630)

請注意,Nessus 並未測試這些問題,而是僅依據應用程式自我報告的版本號碼。

解決方案

升級 php7.4 套件。

針對穩定的發行版本 (bullseye),已在 7.4.33-1+deb11u1 版本中修正這些問題。

另請參閱

https://security-tracker.debian.org/tracker/source-package/php7.4

https://www.debian.org/security/2022/dsa-5277

https://security-tracker.debian.org/tracker/CVE-2022-31628

https://security-tracker.debian.org/tracker/CVE-2022-31629

https://security-tracker.debian.org/tracker/CVE-2022-31630

https://security-tracker.debian.org/tracker/CVE-2022-37454

https://packages.debian.org/source/bullseye/php7.4

Plugin 詳細資訊

嚴重性: Critical

ID: 167434

檔案名稱: debian_DSA-5277.nasl

版本: 1.7

類型: local

代理程式: unix

已發布: 2022/11/14

已更新: 2023/10/4

支援的感應器: Frictionless Assessment Agent, Nessus Agent, Agentless Assessment, Nessus

風險資訊

VPR

風險因素: Medium

分數: 6.7

CVSS v2

風險因素: Critical

基本分數: 10

時間分數: 7.8

媒介: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

CVSS 評分資料來源: CVE-2022-37454

CVSS v3

風險因素: Critical

基本分數: 9.8

時間分數: 8.8

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

時間媒介: CVSS:3.0/E:P/RL:O/RC:C

弱點資訊

CPE: p-cpe:/a:debian:debian_linux:libapache2-mod-php7.4, p-cpe:/a:debian:debian_linux:libphp7.4-embed, p-cpe:/a:debian:debian_linux:php7.4, p-cpe:/a:debian:debian_linux:php7.4-bcmath, p-cpe:/a:debian:debian_linux:php7.4-bz2, p-cpe:/a:debian:debian_linux:php7.4-cgi, p-cpe:/a:debian:debian_linux:php7.4-cli, p-cpe:/a:debian:debian_linux:php7.4-common, p-cpe:/a:debian:debian_linux:php7.4-curl, p-cpe:/a:debian:debian_linux:php7.4-dba, p-cpe:/a:debian:debian_linux:php7.4-dev, p-cpe:/a:debian:debian_linux:php7.4-enchant, p-cpe:/a:debian:debian_linux:php7.4-fpm, p-cpe:/a:debian:debian_linux:php7.4-gd, p-cpe:/a:debian:debian_linux:php7.4-gmp, p-cpe:/a:debian:debian_linux:php7.4-imap, p-cpe:/a:debian:debian_linux:php7.4-interbase, p-cpe:/a:debian:debian_linux:php7.4-intl, p-cpe:/a:debian:debian_linux:php7.4-json, p-cpe:/a:debian:debian_linux:php7.4-ldap, p-cpe:/a:debian:debian_linux:php7.4-mbstring, p-cpe:/a:debian:debian_linux:php7.4-mysql, p-cpe:/a:debian:debian_linux:php7.4-odbc, p-cpe:/a:debian:debian_linux:php7.4-opcache, p-cpe:/a:debian:debian_linux:php7.4-pgsql, p-cpe:/a:debian:debian_linux:php7.4-phpdbg, p-cpe:/a:debian:debian_linux:php7.4-pspell, p-cpe:/a:debian:debian_linux:php7.4-readline, p-cpe:/a:debian:debian_linux:php7.4-snmp, p-cpe:/a:debian:debian_linux:php7.4-soap, p-cpe:/a:debian:debian_linux:php7.4-sqlite3, p-cpe:/a:debian:debian_linux:php7.4-sybase, p-cpe:/a:debian:debian_linux:php7.4-tidy, p-cpe:/a:debian:debian_linux:php7.4-xml, p-cpe:/a:debian:debian_linux:php7.4-xmlrpc, p-cpe:/a:debian:debian_linux:php7.4-xsl, p-cpe:/a:debian:debian_linux:php7.4-zip, cpe:/o:debian:debian_linux:11.0

必要的 KB 項目: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

可被惡意程式利用: true

可輕鬆利用: Exploits are available

修補程式發佈日期: 2022/11/13

弱點發布日期: 2022/9/28

參考資訊

CVE: CVE-2022-31628, CVE-2022-31629, CVE-2022-31630, CVE-2022-37454

IAVA: 2022-A-0515-S