GitLab 14.4 < 15.3.5 / 15.4 < 15.4.4 / 15.5 < 15.5.2 (CVE-2022-3793)

medium Nessus Plugin ID 167261

概要

遠端主機上安裝的 GitLab 版本受到一個弱點影響。

說明

遠端主機上安裝的 GitLab 版本受到下列弱點影響:

- GitLab CE/EE 中存在不當授權問題,此問題會影響 14.4 至 15.3.5、15.4 至15.4.4 以及 15.5 至 15.5.2 的所有版本,攻擊者可藉此直接讀取他們無權存取的 GitLab CI/CD 組態檔案中的變數集。(CVE-2022-3793)

請注意,Nessus 並未測試此問題,而是僅依據應用程式自我報告的版本號碼作出判斷。

解決方案

升級至 GitLab 15.3.5、15.4.4、15.5.2 或更新版本。

另請參閱

http://www.nessus.org/u?407d35a4

Plugin 詳細資訊

嚴重性: Medium

ID: 167261

檔案名稱: gitlab_CVE-2022-3793.nasl

版本: 1.5

類型: combined

代理程式: unix

系列: CGI abuses

已發布: 2022/11/10

已更新: 2024/1/3

支援的感應器: Nessus Agent, Nessus

風險資訊

VPR

風險因素: Low

分數: 1.4

CVSS v2

風險因素: Medium

基本分數: 5

時間分數: 3.7

媒介: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N

CVSS 評分資料來源: CVE-2022-3793

CVSS v3

風險因素: Medium

基本分數: 5.3

時間分數: 4.6

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

時間媒介: CVSS:3.0/E:U/RL:O/RC:C

弱點資訊

CPE: cpe:/a:gitlab:gitlab

必要的 KB 項目: installed_sw/GitLab

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2022/11/2

弱點發布日期: 2022/11/2

參考資訊

CVE: CVE-2022-3793

IAVA: 2022-A-0468-S